Author Topic: What became of M100 Forum?  (Read 1178 times)

Rolo

  • Newbie
  • Posts: 7
  • W116 Enthusiast
  • Location: Portland, Oregon
What became of M100 Forum?
« on: 22 October 2019, 05:06 PM »
I'm a type 116 owner for only the last 35 years and became rather dependent on posts on that forum to keep my car on the road.  I see a number of links in posts on this forum that are all dead.

Did it move, or is it gone?  What about M100 Club?  I was a member as recently as 10 years ago.

daantjie

  • W116 Addict
  • ****
  • Posts: 1,715
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Re: What became of M100 Forum?
« Reply #1 on: 22 October 2019, 05:10 PM »
It is still around but pretty dead:

www.m-100.co

Frankly they failed to keep up with the times, and are still insistent on having a "club" feel to their site.  Of course this is my opinion only,  but I have over 1 000 posts on their forums, and honestly I never felt really at home there.

If you are a 6.9 owner, this is by far the site to be on ;)!
Daniel
1977 450 SEL 6.9 - Astralsilber

arcijack

  • Classic
  • **
  • Posts: 111
  • W116 Enthusiast
  • Location: meridian, mississippi
Re: What became of M100 Forum?
« Reply #2 on: 22 October 2019, 07:20 PM »
i am a paying member of the sight but sometime got the impression the sight was for the elite, i will say, some of the guys would bend over backwards to help you, i have learned a lot from them  but felt more welcomed by the 116 forum

TJ 450

  • W116 Addict
  • ****
  • Posts: 4,149
  • Location: Rockingham, Western Australia
    • Tim's Insulators Downunder
Re: What became of M100 Forum?
« Reply #3 on: 22 October 2019, 09:02 PM »
Yes, it's not very lively these days. I can't remember how to log in so it's in the too hard basket at the moment.  ;D

This is the place for 116 info although the M-100 site is helpful for the other M100s.

Tim
1976 450SEL 6.9 1432
1969 300SEL 6.3 1394
2003 ML500

UTn_boy

  • W116 Addict
  • ****
  • Posts: 1,113
  • Location: knoxville, tn
Re: What became of M100 Forum?
« Reply #4 on: 23 October 2019, 07:18 AM »
Recently, the current president went MIA, the webmaster quit, and past board members refused to help due to their own personal reasons.  So the club was left to crumble.  Yet, they still had Lode Fest in Kentucky last month.  At that meet, they had a meeting and assigned new board members.  I'm not sure who these new board members are, but even so it's still an absolute basket case.  And yeah, it's not a very welcoming site.  It tends to cater to the wealthy elite and not the average Joe.  Lately, it's become a bashing playground for armchair warriors.   Essentially, a bunch of "wanna be" mechanics/technicians try to play hero, but often times it turns into a S*^t show when they're corrected or when their advice ruins someone's car or part they're working on.  Then again, many of the people working on their cars/parts really shouldn't be. However, I can't blame them for wanting to try.   There are very few that know how to work on a 6.9, 600, or 6.3, and the mechanics that are well known are avoided like the plague now due to price gouging and poor morals.  I've tried to renew my membership to continue to help others on the site, but no on can tell me how to due to the new web service having constant problems.  So I'll keep trying, but I make no promises. 
1966 250se coupe`, black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3, papyrus white/dark red leather
1973 300sel 4.5, silver blue metallic/blue leather
1976 280s astral silver/blue MB Tex
1978 450sel 6.9 Euro, Anthr/velour

TJ 450

  • W116 Addict
  • ****
  • Posts: 4,149
  • Location: Rockingham, Western Australia
    • Tim's Insulators Downunder
Re: What became of M100 Forum?
« Reply #5 on: 23 October 2019, 11:05 PM »
Yeah, well I saw a post / thread about someone going on about me taking an MFI pump to a local Diesel injection specialist and they were predicting dire consequences. Well there was a certain amount of truth to it, but it has not been the end of the world. A replacement is now at a specialist now for calibration after having been rebuilt. The original was beyond salvage due to seized elements.

Tim
1976 450SEL 6.9 1432
1969 300SEL 6.3 1394
2003 ML500

UTn_boy

  • W116 Addict
  • ****
  • Posts: 1,113
  • Location: knoxville, tn
Re: What became of M100 Forum?
« Reply #6 on: 24 October 2019, 09:44 AM »
Yeah, well I saw a post / thread about someone going on about me taking an MFI pump to a local Diesel injection specialist and they were predicting dire consequences. Well there was a certain amount of truth to it, but it has not been the end of the world. A replacement is now at a specialist now for calibration after having been rebuilt. The original was beyond salvage due to seized elements.

Tim

I can't speak for Australian repair shops, but here in the States as long as you don't send it to Pacific Fuel Injection you'll come out on top.  Though, buying another pump wasn't necessary, as Bosch is now making new pump elements again. 
1966 250se coupe`, black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3, papyrus white/dark red leather
1973 300sel 4.5, silver blue metallic/blue leather
1976 280s astral silver/blue MB Tex
1978 450sel 6.9 Euro, Anthr/velour

TJ 450

  • W116 Addict
  • ****
  • Posts: 4,149
  • Location: Rockingham, Western Australia
    • Tim's Insulators Downunder
Re: What became of M100 Forum?
« Reply #7 on: 24 October 2019, 09:52 PM »
New elements for the 6.3 pumps? That is surprising. In that case I can also have the original rebuilt as well. Better getting it done sooner rather than later.

Tim
1976 450SEL 6.9 1432
1969 300SEL 6.3 1394
2003 ML500

Rolo

  • Newbie
  • Posts: 7
  • W116 Enthusiast
  • Location: Portland, Oregon
Re: What became of M100 Forum?
« Reply #8 on: 25 October 2019, 02:49 PM »
Like I said in my starter post, I used that site for a several repairs on my 116.  Thanks what's the link to the website, anybody?

rumb

  • W116 Addict
  • ****
  • Posts: 1,366
  • MB Enthusiast
  • Location: Fort Collins, Colorado
Re: What became of M100 Forum?
« Reply #9 on: 25 October 2019, 03:37 PM »
link is in 2nd post.
'68 250S, '77 6.9 euro, '91 300SE, '98 SL500 '14 CLS550

Rolo

  • Newbie
  • Posts: 7
  • W116 Enthusiast
  • Location: Portland, Oregon
Re: What became of M100 Forum?
« Reply #10 on: 10 November 2019, 09:26 PM »
Thanks.  They changed the skin.  Navigation is still a little clunky.

UTn_boy

  • W116 Addict
  • ****
  • Posts: 1,113
  • Location: knoxville, tn
Re: What became of M100 Forum?
« Reply #11 on: 11 November 2019, 02:22 AM »
New elements for the 6.3 pumps? That is surprising. In that case I can also have the original rebuilt as well. Better getting it done sooner rather than later.

Tim

Don't get too excited.  They made a limited quantity, and their cost is a huge turn off. 
1966 250se coupe`, black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3, papyrus white/dark red leather
1973 300sel 4.5, silver blue metallic/blue leather
1976 280s astral silver/blue MB Tex
1978 450sel 6.9 Euro, Anthr/velour