Author Topic: Introducing my "barn find" 6.9  (Read 213 times)

secondslc

  • Enthusiast
  • *
  • Posts: 63
  • W116 Enthusiast
  • Location: Minneapolis
Introducing my "barn find" 6.9
« on: 17 October 2020, 09:21 AM »
Hi Guys,

I've been lurking in the technical forum, trying to get this damn thing to run well enough before it became just another abandoned 6.9.

Long story short, it was a California car that was brought to MN in 1998. It had been here a year before the suspension collapsed and left for dead since. It came out of a garage in South Minneapolis, so it had never really seen salt, and for a W116 is relatively rust free (never say fully rust free of course!)

I spent most of my quarantine weekends working on this damn thing, and it fought me for a while. Before I was able to really feel like this was a car, I had a lot to do... And with the help of you guys...here is what it took to get to today.

-I completely rebuilt the ignition system with a new spark box, coil, distributor cap, resistors, plugs, and grounds.
-Being an electrical engineer, I repaired, re-pinned, re-plugged, and re-wrapped the engine harness.
-I pulled and cleaned the distributor to make sure the vacuum advance was working.
-I re-ran and fixed all the vacuum lines and rubber hoses that had turned rock solid. The car came with everything vacuum related unplugged.
-I pulled the radiator, thermostat, and cleaned all the crud out of the system as best as I could while the garage was near freezing.
-I pulled the transmission cooler and replaced all the lines as most of them had rotted
-I put new belts on as all of them were missing.
-I changed the oil, added brake fluid, transmission fluid, and P/S fluid, hydraulic fluid...all reservoirs were empty.
-I replaced the ignition tumbler the hard way as the key would not turn
-Replaced the injectors, fuel dampener, accumulator, cleaned the pressure regulator in the distributor,  and replaced the air metering plate as mine was warped.
-Replaced all the suspension accumulators and the hydraulic pump. Surprisingly, the one thing that was wrong with the suspension that may have taken it off the road was the pump, once I put that in, the car lifted itself up as if magic.




Whats left to do? Well.. everything lol.
-I am still tuning the fueling, I have two Wideband oxygen sensors installed, trying to get the perfect AFR is a challenge since im new to CIS.
-It doesn't have climate control (the previous owner messed with it a lot)
-It needs brakes all around, the rears don't work and the fronts look fine..but they're old!
-The front suspension leveling valve is leaking.
-Im sure all the struts can use a rebuild, the car drives level but well...im on borrowed time
-The power steering soft lines leak and the wheel feels sloppy.
-It can stand to use all new suspension/steering bushings considering all the rubber has dry-rotted
-I have new door seals for it. The windshield and rear window seals were replaced and perfect.
-The sunroof wont close all the way, and I suspect the drains may be leaking or clogged...
-The interior is a complete black interior made of MB-Tex. Its in great shape but the seats are all mushy.
-The rust I know of is my fault... I washed the car before I put it in the garage. The passenger floor stayed wet for 6 months and now I have surface rust on that side  >:( >:( >:(
-The paint is a thick re-spray from who knows when. Its got orange peel and isn't the nicest. I'll wet sand and buff it to hold me over for now.
-I have European bumpers sitting in my garage, I need to fab brackets for those.
-I want European headlights, but told myself I wont get them till the car can drive, stop, and steer well.

I'm sure there will be more, but there you have it. Another 6.9 mostly on the road.

1979 6.9
1983 urQuattro
1991 200 20V Avant
1993 Corrado SLC
1996 SL600
2009 Super V8

Squiggle Dog

  • W116 Addict
  • ****
  • Posts: 2,089
  • https://fintail.org
  • Location: Surprise, AZ, USA
Re: Introducing my "barn find" 6.9
« Reply #1 on: 17 October 2020, 10:35 AM »
Great progress so far! Don't throw out the USA bumpers after you install the Euro ones; the 6.9 version ones are difficult to find.
Stop paying for animal cruelty and slaughter. Go vegan! https://challenge22.com/

1967 W110 Universal Wagon, Euro, Turbo Diesel, Tail Fins, 4 Speed Manual Column Shift, A/C
1980 W116 300SD Turbo Diesel, DB479 Walnut Brown, Sunroof, Heated Seats, 350,000+

revilla

  • Classic
  • **
  • Posts: 346
  • W116 Enthusiast
  • Location: Aix-en-Provence, France
Re: Introducing my "barn find" 6.9
« Reply #2 on: 17 October 2020, 10:43 AM »
Excellent story. It’s a W116 story of commitment, learning and effort.  Commitment to get the car running. Learning of every bit and principle to fix things. And effort to execute the improvement plan. Bravo!!!

My minuscule 2-cents is maybe to take it one step at a time. Slowly but surely. Do not hesitate please to come back here with questions, if any.



Robert
W116 1977 280SEL & 1979 280SE

daantjie

  • W116 Addict
  • ****
  • Posts: 2,053
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Re: Introducing my "barn find" 6.9
« Reply #3 on: 17 October 2020, 11:05 AM »
Nice work 8)
Indeed "the list" is endless and you really need to pace these jobs so as not to get fatigued with the whole thing.
Daniel
1977 450 SEL 6.9 - Astralsilber

secondslc

  • Enthusiast
  • *
  • Posts: 63
  • W116 Enthusiast
  • Location: Minneapolis
Re: Introducing my "barn find" 6.9
« Reply #4 on: 17 October 2020, 06:44 PM »
Thanks guys!

I guess step one is to get it safe, so the brakes will be done before I drive it to storage which requires some highway riding.

I will say, im trusting the car more and more, and its getting nicer to drive the more I do so. I'll give it the italian tuneup once I know it can stop.... 60mph is already too much, especially on 20+ year old tires.
1979 6.9
1983 urQuattro
1991 200 20V Avant
1993 Corrado SLC
1996 SL600
2009 Super V8

slfan

  • Enthusiast
  • *
  • Posts: 97
  • W116 Enthusiast
  • Location: Miami & São Paulo
Re: Introducing my "barn find" 6.9
« Reply #5 on: 18 October 2020, 10:53 AM »
Congrats on this revival.  You appear to be doing all the right things.  Please share with us your progress.  There are some very knowledgeable and very helpful people here.  I have received a lot of tips here.  You are in the RIGHT place.

Best regards
1978 - 450SEL 6.9 - 3170
1978 - 450SEL 6.9 "Parts Car" - 2973

John Moore Sr

  • Enthusiast
  • *
  • Posts: 16
  • W116 and R/C107 Enthusiast
  • Location: Washington NC
Re: Introducing my "barn find" 6.9
« Reply #6 on: 19 October 2020, 10:57 AM »
Not a bad looking car at all. Welcome to the few and priveledged 036 world. Just remember that we 6.9 owners always have something to do to our beloved cars. JMSr.
1970 300SEL 3.5, 1972 350SLC Euro Parts car, 1974 350SL Euro 3.5 V8 4 speed, 1978 450SLC Euro. 1979 6.9 #4630 1979 6.9 #7003 Parts Car, 1980 450SLC Parts car, 1985 380SL...and once had 1975 6.9 #142 until JuNIOR commandeered it.

raueda1

  • Vintage
  • ***
  • Posts: 622
  • Assimilated. Resistance is futile.
  • Location: Salt Lake City, Utah
Re: Introducing my "barn find" 6.9
« Reply #7 on: 20 October 2020, 06:39 PM »
Wow, great work!  Sounds hauntingly familiar, your list is almost identical to my own. :o  And there's always more, but it's worth it.  Keep us up to date.  Cheers,
-Dave
Now:  '76 6.9 Euro
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0