Garage > Test Drive

Drove 1000miles since Feb things completed/Todo list

(1/1)

Engineerd3d:
When I got my 300sd it had a bunch of the typical problems of the w116. I have put about 1000 miles on it and i can comfortably say she runs better than ever.

This is the list of things that have been done.

1 - Heat on 100% bypassed with a brass nipple. - so far I have used an aftermarket valve to turn off the heat.
2 - AC not working low on freon. Filled it with R12 sealant and basically propane. It's running well.
3 - vacuum leaks galore. - partially fixed as the ac now works as do the central locking system as well as the car finally shuts off reliably
4 - oil filter housing lid pulled the studs out and blew all oil out of engine. Noticed and shut it off right away. Replaced studs with bolt and nut combo. Refilled with oil. No harm thank God.
5 - odometer not working. Fixed with lock tight compound. Showed 173k only broken for 2 months by the previous owner. (Po only owned the car 2 months) paperwork showed 172k. So within error range.
6 - rheostat MIA bad blue leds in the whole car. Replaced with warm white LEDs and reddid the wiring.
7 - trans shifter bushings gone, replaced all bushings with either oem or 3d printed abs bushings. 0 slop on the shifter. Replaced shifter bulb.
8 - Oil gauge leaking. Thread sealant fixed issue. Gauge itself if fine.
9 - tach not working. Tried twice to fix issue. Not having it. May go with other solution.
10 - radio missing replaced with aftermarket with Bluetooth and bypassed the fader rheostat. Not ideal but sounds good.
11 - replaced all 4 tires. The old ones disintegrated. They were 23 years old.
12 - replaced steering dampener.
13 - replaced idler arm bushing. - steering feel is much restored. No other play besides gearbox play.
14 - tightened trans oil lines no more leaking ATF, replenished ATF.
15 - rebuilt the air filter bracket and mounted oem air filter.
16 - replaced sealed beam with H4 housings and LED bulbs.
17 - put in missing fog lamps with aftermarket ones that look similar to the oem Bosch units.
18 - refinished parts of the dash with lacquer and glued the cracked parts back together.
19 - replaced passenger side seat belt that was stuck.
20 - found and replaced seat plastic trim on the sides of the seats.
21 - replaced worn out front power window switches.
22 - rebuilt the hacked up ash tray into a storage cubby and replaced the power socket and made it functional.
23 - repaired the glovebox light and fixed the mounting. Replaced all 5 clips in glovebox
24 - replaced lower fuel filter and put chemicals to clean the fuel tank.
25 - repaired the butchered wiring for the rear cabin lights. Now fully functional.
26 - replaced broken drain line for fuel filler neck reduced wetness in the trunk by a bunch. Still more to come.
27 - tracked down and fixed broken horn.
28 - replaced the burned out bulbs in the center console ac.
29 - replaced bushings in the gas pedal
30 - replaced the gas pedal.
31 - replaced the brake pedal cover.



To do
1 - clean and make the fuel level sensor functional.
2 - replace the lower and upper fuel filter.
3 - get tach working.
4 - install a hidden boost/vacuum gauge to get an idea on the health of the engine and vacuum system.
5 - drain and replace all ATF and trans filter.
6 - replace valve cover gasket
7 - replace lower oil pan gasket.
8 - track down any other oil leaks.
9 - replace all brake lines. ( The ones currently on are not cracked but I would rather replace them) also flush the brake system.
10 - replace the ac system controls with aftermarket and eliminate the Chrysler crap.
11 - keep tracking down vacuum leaks until they are 100% gone.
12 - repair the slight leak under the fuse box.
13 - replace tail light gaskets or fix the leaks.
14 - replace trunk seal. (Have the seal but have not done it yet)
15 - oil change with full synthetic oil.
16 - valve adjustment
18 - ???? Who know what else.

All I know it feels good to have this much done. With way more to come. My 300SD has become my anti stress car. It's finally driving very well and certainly makes the work done worth it. This is my first diesel as well as my first classic car. What a combo!

BCDC:
Very impressive lot of work. Just a thought about the To do list number 2 - replace the lower and upper fuel filter. I'm not totally sure on the diesel cars but what looks like two fuel filters is actually the fuel filter and above that is the accumulator or it is on all the petrol ones with fuel injection.
I would like to know in detail about tracking and fixing the vacuum leaks?

BCDC

Engineerd3d:
The vacuum leaks were separated by circuits. Yellow is the central locking for example, brown is the engine shutoff. Black with green is the ac. For me the ac system leaked. Traced it down with a hand pump. I have an ebay hand pump that i had to replace the O ring on. Less than 20bux. Simply pump a circuit and see which one leaks. Then reseat the connections. If that does not fix it you have diaphragms and or valves that are shot. Mine turned out to be one of the lines that controls the ac servo was leaking badly. Reseated it and glued the rubber fitting back together where it was split with super glue. This helped alleviate the vacuum problem but not 100% fixed. I think removing the center pods vacuum pod completely will help even more. Process of elimination.

Also the diesel does have two fuel filters. 3 if you count the in tank screen. The second fuel filter is right before the canister filter. Diesel injection pumps are very very delicate. I have both filters sitting in a box. But before I go ahead and do this I want to repair the fuel level sender and inspect the tank for alge. I put in alge killer in the last tank of diesel. I will do that again on the next tank.  Waiting on a 46mm socket. For the sender.

ptashek:
That's a job and a half!

Just one point:

--- Quote ---15 - oil change with full synthetic oil.
--- End quote ---

Stick with mineral, or mineral-base semi-synth. Some of the additives in modern full-synth are incompatible with some of the materials used in our engines.

Engineerd3d:
Well I cleaned the sending unit. Not too bad of a job. I tested the unit dry by flipping it end to end. I noticed that the gauge only reads about 3/4 of a tank full and the empty light does function. Looks like the PO messed with the gauge and probably put the needle in the wrong spot. Time will tell, i am planning on running the tank down quite a bit and syphoning the fuel out and cleaning the in tank screen. Apparently it's the same 46mm socket to get this done. I will then fill the tank full and see where the needle ends up. I may adjust the gauge needle.

Navigation

[0] Message Index

Go to full version