Author Topic: What have you done for your W116 today?  (Read 62646 times)

BWalker82

  • Enthusiast
  • *
  • Posts: 39
  • Location: North Atlanta, GA
What have you done for your W116 today?
« on: 18 May 2011, 04:27 PM »
Finally got the 300SD back from the mechanic, new rear wheel bearings and a refurb. power steering gearbox.  The steering is tight now, no more slop.  A little too tight in my opinion, but I won't complain.  It beats the 6" of play prior to the swap.  The clunking (that I was told was the bearings) from the rear is still present (in sharper turns/body roll)... like a metal on metal rubbing "clank".    :-\

My new Tach Amp finally came in and my RPM gauge works great now.   :D  The right side illumination also came to life when I hit a large bump last night, so that's a plus too.  I'm still thinking I need a new Hazard switch or Combo Switch (turn signal/beams) as when I activate the high beams my turn signal lamps come on on the cluster and the gauges illumination dims and flickers.  When I turn on either signal, the clust illumination also blinks.

I pulled the ACC panel out to take a peek inside, but soon felt overwhelmed and just put it all back together.  I'm searching for this infamous green line that activates that blower via switch. Not sure where it is if someone is familiar.  I don't think my blower is operating, but I do hear servos whir to life when I activate different buttons on the panel.

Aside from the citation I received on my joy ride/road trip, I feel confident the car is starting to come back to life after years of storage.   Next up I need to replace engine strut/torque struts and the mounts and then definitely a valve job.  After that, it's all the bs stuff like vacuum locks and ACC.

Cheers!
-BW

thysonsacclaim

  • Vintage
  • ***
  • Posts: 518
  • Location: DeLand, Florida, United States
    • Fortasse | Action at a distance
Re: What have you done for your W116 today?
« Reply #1 on: 20 May 2011, 03:59 PM »
In the last week:

1) Wash, wax and wax again.

2) Scrub, clean, pressure wash and degrease wheel wells in prep for POR-15 coating + hard nose enamel (black). They had a old undercoating which was coming off.

3) Same as above for underside of hood.

4) Clean fuel level sender.

Adam


Fortasse
[Personal Ramblings]
http://www.fortasse.com

Morbid Rodz
[My Brother]
http://www.morbid-rodz.com


1974 450SE, Ikon Gold, Tan interior

1980sdga

  • Vintage
  • ***
  • Posts: 813
  • Location: Ga. USA
Re: What have you done for your W116 today?
« Reply #2 on: 20 May 2011, 05:07 PM »
Where to start...  Been mostly working out the ACC.  It was low on the list but it started interfering with engine shut off  :-\

I think it is going to be OK.  Now if it remains reliable...

I actually think my entire vacuum system is functioning pretty close to perfect  :D

The power lock system blew my mind  ;D  I had no idea it locked the fuel lid and trunk the way it does. Spooky quiet too  8)

 I haven't really done anything with the ALDA and lines that go to the transmission. (I'm guessing it's the modulator?)  It seems to shift OK for now but I plan on going through the transmission checklist. Engine performance seems OK as well.
Jon


Little by little I have grown fond of the infamous Auto Temp II we have in our 116's

Arockz1

  • Newbie
  • Posts: 10
  • 1980 Mercedes 300SD Turbo Diesel
  • Location: Tucker, GA USA
Re: What have you done for your W116 today?
« Reply #3 on: 21 May 2011, 01:16 PM »
Hello I have a 1980 300SD- could you explain a bit more on this noise you have?

Thank you.

" The clunking (that I was told was the bearings) from the rear is still present (in sharper turns/body roll)... like a metal on metal rubbing "clank".   
Rock

BWalker82

  • Enthusiast
  • *
  • Posts: 39
  • Location: North Atlanta, GA
Re: What have you done for your W116 today?
« Reply #4 on: 21 May 2011, 01:26 PM »
It seems that when a rear wheel needs to travel up or down (cornering or a bump), there is a metal on metal sound.  It's as if one piece of metal is turning whilst striking/rubbing another metal part.  

It's a hard noise to explain.  Definitely has the resonance of a moving part though.  As if something metal were rubbing against the wheel/rim, during the cars biased squat in a corner, or going over an uneven surface that raises the wheel.

I will try to peek under there this afternoon.  It's too bloody hot right now to accomplish anything.
« Last Edit: 21 May 2011, 01:29 PM by BWalker82 »
-BW

Arockz1

  • Newbie
  • Posts: 10
  • 1980 Mercedes 300SD Turbo Diesel
  • Location: Tucker, GA USA
Re: What have you done for your W116 today?
« Reply #5 on: 21 May 2011, 01:43 PM »
I have a noise "cluck" with the same movements " SharpTurning" into the driveway or backing out and onto other uneven pavement. But I hear it in the center of the car or body I think. I have had the upper and lower bushings replaced, and other front end work and the transmission mount replaced. I have not touched the rear sub frame bushings or rear trailing arm etc or shocks.

Thanks for your post!
Rock

BWalker82

  • Enthusiast
  • *
  • Posts: 39
  • Location: North Atlanta, GA
Re: What have you done for your W116 today?
« Reply #6 on: 21 May 2011, 01:50 PM »
I have a noise "cluck" with the same movements " SharpTurning" into the driveway or backing out and onto other uneven pavement. But I hear it in the center of the car or body I think. I have had the upper and lower bushings replaced, and other front end work and the transmission mount replaced. I have not touched the rear sub frame bushings or rear trailing arm etc or shocks.

Thanks for your post!

I was thinking the same: rear trailing arm or shocks.
-BW

1980sdga

  • Vintage
  • ***
  • Posts: 813
  • Location: Ga. USA
Re: What have you done for your W116 today?
« Reply #7 on: 21 May 2011, 02:12 PM »
I had my rear sway bar end links go out and it made a terrible noise when cornering.  Easy and cheap fix  ;D
Jon


Little by little I have grown fond of the infamous Auto Temp II we have in our 116's

Janse

  • Classic
  • **
  • Posts: 135
  • Location: Norway
Re: What have you done for your W116 today?
« Reply #8 on: 21 May 2011, 02:39 PM »
Found a puddle of oil on the floor under the engine today... but it is probably just a bad gasket in the servo pump. Still working on the cooling for the carb, looks like it will come together next week, also my little issue with the oil pressure sensor. We are having a spring meeting in the lokal Mercedes Club on the 28th of may so I am hoping to get my car ready by then.

jbrasile

  • W116 Addict
  • ****
  • Posts: 1,217
Re: What have you done for your W116 today?
« Reply #9 on: 21 May 2011, 04:13 PM »
1980sdga is right with regards to the noise from the rear suspension, from the description of those with the problem the sway bar links are usually the culprit.

Tks,

Joe

thysonsacclaim

  • Vintage
  • ***
  • Posts: 518
  • Location: DeLand, Florida, United States
    • Fortasse | Action at a distance
Re: What have you done for your W116 today?
« Reply #10 on: 21 May 2011, 05:21 PM »
Yes those sway bar links sound HORRIBLE when they break, often rubbing on the rim.

Mine were bad and I got the most awful sound backing out of my driveway, which is is sloped.

The ones with the plastic bits with blue collars seem less sturdy and I had no idea what to do with the collar part; not sure if it was just for shipping as they wouldn't go on with them attached and no instructions about it.

Cheers
Adam


Fortasse
[Personal Ramblings]
http://www.fortasse.com

Morbid Rodz
[My Brother]
http://www.morbid-rodz.com


1974 450SE, Ikon Gold, Tan interior

scraf

  • Classic
  • **
  • Posts: 332
  • Location: Netherlands
Re: What have you done for your W116 today?
« Reply #11 on: 21 May 2011, 11:45 PM »
Right at the moment a helpful chap is replacing an axle for me, car sounds like a horse galloping on tiles when going slow with four people in it, hardly any problem when I'm in it alone.

With weight in it I've also had to stop accelerating around right hand bends on the motorway, makes my driving style somewhat inconsistent.

Will know tonight if it was the correct fix. 
Mercedes 450SEL 1975 Pimp mobile
Mercedes 306D 1975 Ska mobile ( in hibernation )
Mercedes 300D 1974 W114 Ambulance

UTn_boy

  • W116 Addict
  • ****
  • Posts: 1,052
  • Location: knoxville, tn
Re: What have you done for your W116 today?
« Reply #12 on: 22 May 2011, 02:40 AM »
Today? nothing other than fill its fuel tank up again.  Yeah, it gets 12-14 miles to the gallon, but it is so nice to drive.  It turned over 66,000 miles the other day, and when the odometer read 66,006, the alternator light came on. :-/.  It's the original one, and I already replaced the rectifier once, so I think a new one is in order.

In the last six months this is what i have done.  I replaced all the front end and rear end bushings, ball joints, etc, new steering coupling, all new steering and idler arm bushings, new motor mounts and engine shocks, new set of michelin tires, new head light doors and turn signal lenses, new amber fog lamp lenses, (the clear ones are pretty much useless), new brake lines, master cylinder, and brake booster, I put new horse hair pads in both front seats and the rear as well, replaced rear glass seal and front glass seal, new water pump, rebuilt a/c compressor, new drier, cleaned expansion valve, (the new ones you get are unfortunately calibrated for R-134 A), flushed the system, put fresh mineral oil back in it, and filled it with a fresh 2 pounds of R-12.  (for those of you reading that remember the a/c talk you had with me, I did do the evacuation correctly, haha).  Let's see, I also took three climate control servos I had lying around and made one good one,  new amplifier, Installed a Becker Mexico Cassette, new speakers, new trunk seal, new tail light seals, cleaned and polished tail lamp lenses while they were out, new grill insert and trim mouldings that go on it, new hood star and rosette, new grill badge, cleaned and painted all four wheel wells while suspension was out, cleaned and painted inside and outside of steel rims, repaired vacuum actuators in doors and replaced the trunk lock actuator, new cruise control cable, changed out carburtetor to one that has no warpage, cleaned door jambs and greased door hinges, re padded perforated panels on door panels, replaced fuel tank, new fuel pump, all new belts, hoses, fluids/filters, adjusted valve lash and renewed tappet cover seals, new timing chain and tensioner, new crankshaft seal, new battery, new windshield washer pump and reservoir, new hood pad, new driveshaft center support bushing and bearing, new flex disc (front and rear), resealed differential, new differential mount, new exhaust, gutted catalytic converter, polished all anodized aluminum (came out looking like new by using 3M rubbing compound), cleaned and polished inner fender wells in engine bay, cleaned all vacuum hoses and wiring in engine bay, new shift linkage bushings and shift gate housing bushings, renewed bushing on kick down rod that goes from accelerator linkage to transmission, new Bilstein shocks all around, removed the transmission and renewed the torque converter seal, front pump seal, and output shaft seal, and last but not least, a good cleaning on the inside.   Even the wood looks new, no fading, hazing, or cracking.  All the carpet, even in the rear glass area, as been covered up its whole life.  I still have the original coco mats, too. The blue MB tex is flawless, and even the center console isn't faded too bad.   

I did every bit of this work with the exceptions of tire mounting and front end alignment. Having said that, you get really emotionally attached to the car and learn its personality.  I wanted to sell it, but found that doing so was a really hard idea to swallow.  The thought of someone else driving and owning my 280s not taking care of it like i would sickened me.  This is really interfering with my purchasing a W108 280sel 4.5 that I have wanted for ten years.  So I suppose I'll have to keep the W116, and in addition buy my W108. 

I drive my 280s almost daily, and it'll go anywhere I need it to, locally or nationwide.  I almost have the car perfect in every aspect.  All that needs attention now is the paint, but that is another $5,000 at least.  You ask yourself, "So where do I stop?".  It'll always be something, new or old.  It's been a long and grueling 6 months, but It was so worth it, and having automatic climate control that works perfectly in a W116 is so unusual, but very satisfying. haha.  Hope all of you are doing well.  take care, AARON
1966 250se coupe`, black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3, papyrus white/dark red leather
1973 300sel 4.5, silver blue metallic/blue leather
1976 280s astral silver/blue MB Tex
1978 450sel 6.9 Euro, Anthr/velour

Big_Richard

  • Guest
Re: What have you done for your W116 today?
« Reply #13 on: 22 May 2011, 04:15 AM »
I washed my car today.  8)


VERY overdue.

koan

  • W116 Addict
  • ****
  • Posts: 3,314
  • Location: Melbourne
Re: What have you done for your W116 today?
« Reply #14 on: 23 May 2011, 12:30 AM »
Ordered a new number plate for the front and screwed the old one back on temporarily. I managed to close the tilting garage door with the car too far forward, the door came down and ripped the plate clean off, the plastic mounts survived but they are now a touch distorted after being pulled out of the slots.

And put $115 of petrol in the beast.

koan
Boogity, Boogity, Boogity, Amen!