Author Topic: Turn signal post troubles  (Read 1437 times)

Matt350se

  • Newbie
  • Posts: 8
  • Location: Nottingham Road, South Africa
Turn signal post troubles
« on: 05 July 2006, 11:14 AM »
Greetings all,
I am the proud new owner of a 1975 350se (bought on auction in amazing condition Durban SA) and want to say how useful your posts and advice have been to me.

Ill be doing some restoration work on the car though, and want to know if anyone has experienced probs with the turn-signal post. Mine has to be depressed quite hard (and with what i can only describe as some follow-through!) to engage for both L and R. Is this mechanism something that can be fixed?

Also, does anyone know a brand or type of speaker that sits nicely in the dash panel?

cheers,

Matt
1975 350 SE

oscar

  • W116 Addict
  • ****
  • Posts: 4,043
  • Location: Riverina, NSW, AUSTRALIA
Re: Turn signal post troubles
« Reply #1 on: 05 July 2006, 05:36 PM »
Hey Matt, welcome.  Great choice of 116 I might add.  ;D

Re your signals, once you get the indicators on, do they have trouble staying on or or do you have to force the arm back to neutral.

Here's a thread that may help and if it doesn't, it should give you some idea on how the mech should work.  Usually the switch gets "sloppy" rather than gets harder to move.  I wonder if someone has rearranged the springs or already tried to grind out the mech but made it worse.  Anyway, follow that link and refer to the pic to see how different yours looks.   NB the lower spring in that pic should be attached to both turn pins. Cheers.
1973 350SE, my first & fave

s class

  • W116 Addict
  • ****
  • Posts: 4,171
  • I'll keep the 116's, the rest can go
  • Location: Squeezing 3 W116's into a double garage
Re: Turn signal post troubles
« Reply #2 on: 06 July 2006, 12:10 AM »
Matt,

Welcome to the group.

Would that be Durban SOUTH AFRICA?

If so, then it makes two of us Seth Ufrikuns on this site.  I used to live in Durban myself with my 280SE

'76 6.9 Euro, '78 6.9 AMG, '80 280SE, '74 350SE, '82 500SEL euro full hydro, '83 500SEL euro full hydro , '81 500SL

Matt350se

  • Newbie
  • Posts: 8
  • Location: Nottingham Road, South Africa
Re: Turn signal post troubles
« Reply #3 on: 06 July 2006, 11:28 AM »
Thanks for the thread oscar, im gonna hit the problem with my dremel next week.
durban South Africa it is in deed s class! just moved back here form the UK and fallen in love with driving again (hence my joy at finding a 350 se!). 
1975 350 SE