News:

www.W116.org
The #1 resource for our W116! Established 2004

Main Menu

Sudden rough idle

Started by 1980450sel, 18 January 2010, 01:13 AM

1980450sel

Hello everyone,

I ran my 1980 450 this afternoon and it idled nicely, this evening I went for a short run and it was fine and I stoppped at a store, bought a few things and it started fine so I thought let's see how she does, so I stepped on it and it bucked and sputtered and I barely made it home which was just a few blocks away. I had to keep restarting it and pumping the accelerator just to get it up the incline to my garage. Where should I start looking? ???

Scott

1980450sel

Hey guys, is it possible that under load that the timing chain could have skipped a cog? Has this happened to any one?

Scott

nathan

i would have thought a slipped timing chain would be more catastrophic? ill leave it to the mechanics on teh board.  does it sound more like a fuel issue here?
1979 116 6.9 #6436
2018 213 e63
2011 212 e63
2011 463 g55
2007 211 e500 wagen
1995 124 e320 cabriolet
1983 460 300gd
1981 123 280te

flutes

Matt
1977 450SEL

koan

Quote from: 1980450sel on 18 January 2010, 01:13 AM
Where should I start looking? ???

What's it like when you try to start it now, is it drowning in fuel, clouds of black smoke, stinking of fuel, or is it short of fuel, reluctant to start and backfiring?

koan
Boogity, Boogity, Boogity, Amen!

s class

This sounds like a classic blocked fuel filter scenario. 


[color=blue]'76 6.9 Euro[/color], [color=red]'78 6.9 AMG[/color], '80 280SE, [color=brown]'74 350SE[/color], [color=black]'82 500SEL euro full hydro, '83 500SEL euro full hydro [/color], '81 500SL

brettj

Funny my car has been doing the same thing. I've decided that I have a fuel injector issue which is most likely electrical. I have 8 brand new injectors ready for installation. The only problem is that it is so cold out here I don't want to work outside  on my car! Anyway, I think you have a fuel injection problem.

1980450sel

Yes, as you may or may not remember when I got the car it had been sitting for 3 years (older post) with about an 1/8th of a tank of gas. The tank was full of rust and the fuel pump was toast. I replaced the pump and filter and removed the tank and cleaned it with some etching chemical. Some older wiser gents told me that I should take the tank to a rad shop to have it soaked and steamed. I think I should have listened to them. I'm going to remove my fuel filter and see how things look but I have a feeling the tanks coming out again. If a rusty fuel system is the cause, this may be a very valuable lesson for me, listen to older wiser gents!

Scott

WGB

Doesn't sound like a timing chain - I think the rust in the filter or water in the fuel is much more likely.

Have you simply tried a new filter and a couple of bottles of injector cleaner in the tank?

Bill

koan

Quote from: 1980450sel on 18 January 2010, 04:45 PM
I'm going to remove my fuel filter and see how things look but I have a feeling the tanks coming out again. If a rusty fuel system is the cause, this may be a very valuable lesson for me, listen to older wiser gents!

It will be lean and backfiring especially when cold if the filter is really blocked, that's why ask if rich or lean on starting.

Why would the filter suddenly block up though, usually a gradual thing.

koan
Boogity, Boogity, Boogity, Amen!

s class

I once had a situation with my 280SE where it was driving fine, and within 10km went from fine, to stumbling, to completely dead andhaving to be towed home.  THe problem was a blocked fuel filter. 


[color=blue]'76 6.9 Euro[/color], [color=red]'78 6.9 AMG[/color], '80 280SE, [color=brown]'74 350SE[/color], [color=black]'82 500SEL euro full hydro, '83 500SEL euro full hydro [/color], '81 500SL

benzjarr

I had the same problems with my 1979 450sel it was leaking vacuum line under the hood. Replaced it with general vacuum tubing now idles perfect. Thats if the fuel filter don't work

1980450sel

Well the gas tank is out again, sure enough lots of loose rust inside. I dropped it off today to be steamed and acidized. Hopefully that does the trick.

Scott

zedster

Scott it is because you took out the radio and sent it to me. LOL
1979 450 SEL "Spinne Blaue"