Author Topic: Sudden rough idle  (Read 2745 times)

1980450sel

  • Enthusiast
  • *
  • Posts: 80
  • "I've been chatting online with babes all day "
  • Location: Alberta, Canada
Sudden rough idle
« on: 17 January 2010, 10:13 PM »
Hello everyone,

I ran my 1980 450 this afternoon and it idled nicely, this evening I went for a short run and it was fine and I stoppped at a store, bought a few things and it started fine so I thought let's see how she does, so I stepped on it and it bucked and sputtered and I barely made it home which was just a few blocks away. I had to keep restarting it and pumping the accelerator just to get it up the incline to my garage. Where should I start looking? ???

Scott
1980 450 SEL

1980450sel

  • Enthusiast
  • *
  • Posts: 80
  • "I've been chatting online with babes all day "
  • Location: Alberta, Canada
Re: Sudden rough idle
« Reply #1 on: 18 January 2010, 07:45 AM »
Hey guys, is it possible that under load that the timing chain could have skipped a cog? Has this happened to any one?

Scott
1980 450 SEL

nathan

  • W116 Addict
  • ****
  • Posts: 1,687
  • Location: perth, western australia
Re: Sudden rough idle
« Reply #2 on: 18 January 2010, 07:57 AM »
i would have thought a slipped timing chain would be more catastrophic? ill leave it to the mechanics on teh board.  does it sound more like a fuel issue here?
6.9 79 #6436
6.9 79 #6290
6.9 79 #6181
6.9 78 #4764
6.9 77 #3096
6.9 76 #1741
6.9 76 #0902
6.9 75 #0018

flutes

  • Classic
  • **
  • Posts: 353
  • Location: Sydney
Re: Sudden rough idle
« Reply #3 on: 18 January 2010, 08:00 AM »
Temperature issue?
Matt
1977 450SEL

koan

  • W116 Addict
  • ****
  • Posts: 3,314
  • Location: Melbourne
Re: Sudden rough idle
« Reply #4 on: 18 January 2010, 12:49 PM »
Where should I start looking? ???

What's it like when you try to start it now, is it drowning in fuel, clouds of black smoke, stinking of fuel, or is it short of fuel, reluctant to start and backfiring?

koan
Boogity, Boogity, Boogity, Amen!

s class

  • W116 Addict
  • ****
  • Posts: 4,152
  • I'll keep the 116's, the rest can go
  • Location: Squeezing 3 W116's into a double garage
Re: Sudden rough idle
« Reply #5 on: 18 January 2010, 01:25 PM »
This sounds like a classic blocked fuel filter scenario. 

'76 6.9 Euro, '78 6.9 AMG, '80 280SE, '74 350SE, '82 500SEL euro full hydro, '83 500SEL euro full hydro , '81 500SL

brettj

  • Vintage
  • ***
  • Posts: 518
  • 1975 450SE
  • Location: Massachusetts, USA
Re: Sudden rough idle
« Reply #6 on: 18 January 2010, 01:31 PM »
Funny my car has been doing the same thing. I've decided that I have a fuel injector issue which is most likely electrical. I have 8 brand new injectors ready for installation. The only problem is that it is so cold out here I don't want to work outside  on my car! Anyway, I think you have a fuel injection problem.

1980450sel

  • Enthusiast
  • *
  • Posts: 80
  • "I've been chatting online with babes all day "
  • Location: Alberta, Canada
Re: Sudden rough idle
« Reply #7 on: 18 January 2010, 01:45 PM »
Yes, as you may or may not remember when I got the car it had been sitting for 3 years (older post) with about an 1/8th of a tank of gas. The tank was full of rust and the fuel pump was toast. I replaced the pump and filter and removed the tank and cleaned it with some etching chemical. Some older wiser gents told me that I should take the tank to a rad shop to have it soaked and steamed. I think I should have listened to them. I'm going to remove my fuel filter and see how things look but I have a feeling the tanks coming out again. If a rusty fuel system is the cause, this may be a very valuable lesson for me, listen to older wiser gents!

Scott
1980 450 SEL

WGB

  • W116 Addict
  • ****
  • Posts: 3,280
  • And on the eighth day he made the 116
  • Location: Perth - Western Australia
Re: Sudden rough idle
« Reply #8 on: 18 January 2010, 03:11 PM »
Doesn't sound like a timing chain - I think the rust in the filter or water in the fuel is much more likely.

Have you simply tried a new filter and a couple of bottles of injector cleaner in the tank?

Bill

koan

  • W116 Addict
  • ****
  • Posts: 3,314
  • Location: Melbourne
Re: Sudden rough idle
« Reply #9 on: 18 January 2010, 07:02 PM »
I'm going to remove my fuel filter and see how things look but I have a feeling the tanks coming out again. If a rusty fuel system is the cause, this may be a very valuable lesson for me, listen to older wiser gents!

It will be lean and backfiring especially when cold if the filter is really blocked, that's why ask if rich or lean on starting.

Why would the filter suddenly block up though, usually a gradual thing.

koan
Boogity, Boogity, Boogity, Amen!

s class

  • W116 Addict
  • ****
  • Posts: 4,152
  • I'll keep the 116's, the rest can go
  • Location: Squeezing 3 W116's into a double garage
Re: Sudden rough idle
« Reply #10 on: 18 January 2010, 08:40 PM »
I once had a situation with my 280SE where it was driving fine, and within 10km went from fine, to stumbling, to completely dead andhaving to be towed home.  THe problem was a blocked fuel filter. 

'76 6.9 Euro, '78 6.9 AMG, '80 280SE, '74 350SE, '82 500SEL euro full hydro, '83 500SEL euro full hydro , '81 500SL

benzjarr

  • Enthusiast
  • *
  • Posts: 83
  • Location: Knoxville TN U.S.A
Re: Sudden rough idle
« Reply #11 on: 18 January 2010, 11:15 PM »
I had the same problems with my 1979 450sel it was leaking vacuum line under the hood. Replaced it with general vacuum tubing now idles perfect. Thats if the fuel filter don't work
C126 DRIVER
HAD A 450SEL DISTROYED BY HAIL

1980450sel

  • Enthusiast
  • *
  • Posts: 80
  • "I've been chatting online with babes all day "
  • Location: Alberta, Canada
Re: Sudden rough idle
« Reply #12 on: 22 February 2010, 12:48 PM »
Well the gas tank is out again, sure enough lots of loose rust inside. I dropped it off today to be steamed and acidized. Hopefully that does the trick.

Scott
1980 450 SEL

zedster

  • Classic
  • **
  • Posts: 203
  • Location: Las Vegas, NV, USA
Re: Sudden rough idle
« Reply #13 on: 23 February 2010, 12:09 PM »
Scott it is because you took out the radio and sent it to me. LOL
1979 450 SEL "Spinne Blaue"