Forum

Garage => Mechanicals => Topic started by: OLDGOLD on 29 October 2018, 07:53 PM

Title: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 29 October 2018, 07:53 PM
When I rev my 300SD up to even a few thousand RPM's at idle, when the needle comes back down, the engine seems like it turns off for a split millisecond, and then goes back to the normal RPM range. When this happens the engine shakes hard once, and then goes back to a healthy idle. The engine is strong and responsive, but the shutter doesn't seem right and after watching videos of other 617 diesels, I know it shouldn't do this. Something is causing my RPM's to briefly go lower than they should. This seems to occur more at warm up, but can happen when the engine is warm as well. Any help would be appreciated.
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 29 October 2018, 09:32 PM
The 'hiccup' is probably due to an air incursion located pre-lift pump.

The strong suction generated by the lift pump can pull in air and cause a stumble on return to idle.
Usual suspects are the hoses connected to the primary fuel filter, and also the primer pump.

Do you see any air bubbles in the return line when you blip the revs?
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 02 November 2018, 09:56 AM
I’ll check and find out. Thanks!
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 03 November 2018, 10:54 AM

Ideally the fuel circuit should be entirely free of air while the fuel travels from the tank, through the primary fuel filter, lift pump, secondary fuel filter, IP,  and finally back to the tank.

Inspecting for air:

The clear line to inspect is the one with the T fitting on top of the fuel filter head.
The line is probably a deep brown color from fuel varnish if it is original.
If there is any air in it with the engine off, you have an air incursion.
If you see a stream of small bubbles in the line when you rev the engine, you have also an air incursion under load.

A small flashlight placed directly against the line can help  show if there is air in an older fuel stained return fuel line.

Any opening of the fuel circuit, (like changing the primary clear fuel filter, activating the primer pump, or changing a secondary fuel filter) can cause an air incursion if not resealed properly.
Use new crush washers, o-rings, and rubber/Viton fuel hoses to properly reseal the fuel unions.

The usual suspects:

When replacing the primary fuel filter, the short rubber hoses should be replaced.
Stock fuel hose is metric (7.5 X 13.5) which is not readily available at the local auto parts store.

Many substitute 5/16 fuel hose which is a little loose and this can cause an air incursion, especially if
you don't use a primary fuel filter with bronze inserts (Hebmuller), and quality ABA or Norma style fuel clamps that are cinched down tightly.
When cinched  tight enough, you should not be able to rotate the filter/hose union by hand.

I like to have the option of being able to run biodiesel so I've installed 5/16 Parker Super-Flex FL 397 hose on 'Desert Rose'
Unfortunately I have not found a metric equivalent...yet.

The '01' secondary fuel head hollow bolt needs a new crush washer and a new o-ring when you install a new secondary metal fuel filter.
The '02' secondary fuel filter head has a better sealing hollow bolt that uses two o-rings.
I have the ''02 ' fuel filter heads on my W116 300SDs.

If the primer pump leaks fuel when you manually activate it , you will get an air incursion as well.
The old style primer pumps are notorious for causing air leaks.
The black Bosch pushbutton style primer pumps are less likely to leak.
(Beware of inexpensive counterfeit Bosch primer pumps...they will leak)

Other less common suspects:
Pinhole leaks in the exposed metal fuel lines, especially under the rubber buffers in the brackets securing the lines to the body.

The clear lines attached to the IP can develop cracks, especially at the end of the barbed fittings.

Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 03 November 2018, 11:44 AM
Thank you so much for your thorough explanation of possible culprits. I may just buy a Monark metal primer pump from Mercedessource and not worry about buying a knock-off by mistake. Thanks again!
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 03 November 2018, 05:23 PM
Well I'll be darned! Upon inspection of the fuel line while under heavy load, I noticed a very fast stream of bubbles once the revs hit around 4k. I had to hold the flashlight from my iPhone directly up to the underside of the hose to see through the brown varnishing. I checked the primer pump and once I got the handle loosened, diesel fuel started to leak then gush when I primed the pump. It looks like I'll be replacing the primer pump asap.

Do you have a link to a site where I might find the 7.5 X 13.5 hose you were speaking of?
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 03 November 2018, 07:37 PM
Here are three sites, I've only ordered from PelicanParts and koperformance:

 
https://www.pelicanparts.com/catalog/SuperCat/3332/MBZ_3332_FULFUL_pg2.htm#item2
Cohline Part #: 21340600-M20 @ $7.00 sold by the meter
and Cohline Part #: 22400600-M20 @$19.50 sold by the meter (Low permeation - suitable for biodiesel).



http://www.koperformance.com/online_ordering/search_catalog.php?q=21340600

http://www.koperformance.com/online_ordering/search_catalog.php?q=22400600



https://www.rmeuropean.com/Products/21340600-MFG20.aspx?gclid=Cj038TP6N0-Vhuyd79lVy4W4E2Kwu8m6U6PD_3zoPa7WEC88IaAk6pEALw_wcB

https://www.rmeuropean.com/Products/22400600-MFG20.aspx


PelicanParts offers free shipping on orders of $99 or more.
They also carry the real Bosch  pushbutton style primer pump - Part #: 000-090-88-50-M14
https://www.pelicanparts.com/catalog/SuperCat/3332/MBZ_3332_FULFUL_pg2.htm#item2

I'll probably be ordering some of the Cohline  22400600 biodiesel compatible hose for 'Stormcloud' from PelicanParts as part of my next $99+ order.
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 04 November 2018, 06:06 PM
Thank you. This seems to be the clear tubing coming off of the primary fuel filter. Thank you to whomever found this from other threads on this subject...
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 04 November 2018, 08:30 PM
Agreed, AKAIK MB did use metric Tyogothane hose for the 3 clear lines attached to the fuel filter head.
Just to be clear, the metal spin-on fuel filter is the secondary fuel filter, and the clear plastic fuel filter is the primary fuel filter. :)
The rubber hoses attached to the primary fuel filter are the ones most likely to leak.

If at some point you are planning to replace your fuel stained clear lines,
I'd recommend getting the genuine MB parts.

(This year I've been using mboemparts.com for discounted dealer
parts...and the BENZWORLD2017 promo code for free shipping).

The genuine MB lines are completely transparent, and install with ease.

The Cohine brand lines fit well, are less costly, but the lines are semi-opaque and a bit stiff
Reusing the old barbed fittings with new hose is also possible, but this can be a bit of a challange.


Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 05 November 2018, 07:23 PM
Thank you for setting me straight on the fuel filters, I always thought it was the other way around. I don't think I'm the only one either!

I actually ordered some clear line from a dealer in Fontana, California that stocked it (MB seems to stock a ton of vintage parts out there in Fontana). I work in the service department of an MB dealer in Dallas, and get a decent discount. It was around $75 list for the line. I was hoping we had it in stock and could just cut it by the yard, I was mistaken. That would've been too easy. If it's that much easier to install the genuine hose, I'm glad I'm doing that instead.

I decided to order the updated Bosch primer pump from Amazon. I got the only one that said "Brand: Bosch" in the description. All the other listings looked like they were knock offs.
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 19 November 2018, 05:47 PM
Alrighty, well I've changed out just about every line going into and out of both fuel filters. The lines weren't stupid expensive, but I would suggest reusing the fittings on the ends of the clear fuel lines and using a similar hose rated for fuel use if you wanted to save money. Although, according to Kent, he's never had very good luck finding a hose that works as well or better than the genuine. My trusty old-timer technician suggested that instead of using the steel or aluminum washers for the fittings, use copper ones instead. So I used them on every bolt.

I also replaced the primer pump with a Bosch updated unit, the hoses to-and-from the inline filter, and the "pregnant hose" going into the secondary fuel filter. I went ahead and replaced both filters while I was at it.

I'm happy to report that the stutter back to idle seems to have been reduced significantly. One thing that I did notice is that the line directly forward of the primer pump does seem to have quite a few small bubbles at high rpm's, but as I understand it this is a return line. Please correct me if I'm wrong.

One last question... I've seen a few people use clear fuel line in place of the braided fuel line on the injectors. Would that type of line have lesser of a seal than the braided hoses?

Thank you Alec. You have been an invaluable resource!
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 19 November 2018, 08:51 PM
It appears you may have inadvertently installed the pressure relief valve in the incorrect position.

The pressure relief valve is the hollow bolt with the cap bolt that is presently installed
on the T- banjo fitting atop the fuel filter head.
It should be installed on the other end of that clear line.. on the IP side just next to the engine.


If you still have air bubbles,  there is stlill some air ingess.
Have you replaced  both seals on the large hollow bolt for the secondary metal spin-on fuel filter?
Does the primary plastic fuel filter have bronze inserts?

The clear injector retun lines (tygon - for lawn mowers, etc.) seal well initially,
but only tend to last about a year or so from what  I  have heard.
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 19 November 2018, 09:42 PM
Yes, I did replace the o-rings in the secondary filter. What do mean by bronze inserts? It’s an MB primary filter.

Can you show me a pic of what my lines should look like or circle where I went wrong please? I’ve compared it to yours and they look the same.
Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 19 November 2018, 11:42 PM
The MB primary fuel filter is a great filter.
No need to change it out.
I just prefer to use a Hebmuller filter.
The Hebmuller filter is more translucent and has bronze inserts that resist crushing by the hose clamps.
https://www.carid.com/hebmuller/fuel-filter.html

Here a picture of the performance overflow valves installed in ''Desert Rose' and 'Stormcloud'.
http://www.peachparts.com/shopforum/diesel-performance-tuning/361825-performance-overflow-valve.html

It is just a hollow bolt with cap bolt that houses a ball beaing, a spring and is sealed with a small crush washer.
http://handbook.w116.org/Engine/617/07_1-145.pdf


You have installed yours on the fuel filter head, it belongs on the IP.
Attached are photos of the setup  on 'Stormcloud'. :)
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 20 November 2018, 05:59 PM
I feel stupid. I had to correct it right after work. Whats the worst thing that could happen if I had left the PRV in the incorrect position.

I was speaking with an individual that worked on these cars back in the 80's, and he thought the rack dampener bolt could have something to do with the stutter. Could this be the case?

Title: Re: OM617 engine shutter after revving at idle
Post by: Alec300SD on 20 November 2018, 08:08 PM
We all make mistakes some times (filling the engine with oil with the drain plug out, etc.)
Worst case scenario with the PRV in the incorrect position could be a minor loss of some power/responsiveness.

If worn excessively (or out of adjustment) the rack damper bolt can definitely affect the return to idle adversely.

Most likely culprits affecting engine performance at warm up are air ingress, clogged fuel filters, low cetane fuel, water in fuel, dirty fuel tank/fuel strainer, tight valves, poor injector spray pattern, glow plug failure, and a dirty air filter...just to name a few.

I'd address those areas before looking at the rack damper bolt.

The diesels respond well to being driven spiritedly on a regular basis.






Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 21 November 2018, 10:07 AM
OK, I replaced the rack dampener bolt last year, but I'm not sure if it was adjusted correctly.

I just replaced all the fuel filters last week, the air filter a few months ago, had a valve adjustment less than a year/5k miles ago, new Monark nozzles less than 6 months ago and I use Shell V-Power Diesel with TK-7 additive (w/ cetane booster) only at every fueling. I haven't check the fuel screen, but I will eventually replace that as well.

I'll try adjusting the RDB soon and let you know what happens.

Thanks!
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 18 July 2019, 01:30 PM
I just realized something when watching a MS video on YT. I noticed that when he was revving up a 240D from the linkages by hand, how smoothly it settled back to idle with not even a hint of a stumble. (https://www.youtube.com/watch?v=uO_QO2lPbWU&list=PLtRKk64pu2wpQBZU9mSxKU2Wb-iSabXIT&index=6 at the 2:39 mark) I saw that when he released the linkages, they smoothly went back into their resting position almost like fancy soft-close kitchen cabinets. I do know that the linkages changed from chassis to chassis or from year to year, but could the linkages be causing the engine to rev lower than it should when rebased back?

My fuel system is in top notch condition with a recent purge, monarch nozzles, new fuel filters with Hebmuller primary and Mann secondary, new lines and primer pump as well. There has to be something causing the strong stumble on return to idle. Please help!
Title: Re: OM617 engine shutter after revving at idle
Post by: Squiggle Dog on 18 July 2019, 08:29 PM
My roommate's 1991 W126 350SDL does this! When the accelerator pedal is let off, the linkages slam down and push against the injection in the opposite direction and about shuts off the engine. Taking the slack out of the linkage seems like it might have helped a little, but didn't solve it. There may be a spring missing.
Title: Re: OM617 engine shutter after revving at idle
Post by: OLDGOLD on 19 July 2019, 12:26 PM
Does your 300SD have a linkage spring?
Title: Re: OM617 engine shutter after revving at idle
Post by: Squiggle Dog on 23 July 2019, 01:03 PM
Does your 300SD have a linkage spring?

I looked and didn't see one on mine, just the one at the accelerator pedal on the cabin side of the firewall.