News:

www.W116.org
The #1 resource for our W116! Established 2004

Main Menu

No brake lights

Started by daantjie, 19 June 2022, 10:42 PM

daantjie

It never ends...

Seems I lost brake lights all of a sudden :o

Fuse checks out.  All bulbs fine.  Leaves only the switch on the pedal, right?

Is there a test for the switch?  Seems like with pedal at rest the switch is open, then as you press the pedal the trigger opens up and completes the circuit?

Any tips appreciated before I throw a new switch at the problem  ;D

Cheers
Daniel
1977 450 SEL 6.9 - Astralsilber

daantjie

The plot thickens...

I bridged the switch at the harness and I see only left rear brake light on.  Hmm...

Also this brake light only works with ignition in ON.  Not sure if this is right?

I recall reading the cruise control grounds via the brake light bulb(s)?  So maybe I have an issue with cruise control?  I never use cruise control so not sure what is going on here.  I would think that brake lights should override cruise control for safety reasons?
Daniel
1977 450 SEL 6.9 - Astralsilber

rumb

With a meter you should be able to see if the switch is working.
'68 250S
'77 6.9 Euro
'91 300SE,
'98 SL500
'14 CLS550,
'16 AMG GTS

daantjie

Quote from: rumb on 20 June 2022, 09:01 AMWith a meter you should be able to see if the switch is working.

Thanks Robert I tested for resistance and it seems to be working in that it goes open with the button pushed in so looks like the switch is good.  Checking all bulbs again, this is reading like a poor contact somewhere.
Daniel
1977 450 SEL 6.9 - Astralsilber

rumb

Always worth checking grounds on any circuit.
'68 250S
'77 6.9 Euro
'91 300SE,
'98 SL500
'14 CLS550,
'16 AMG GTS

daantjie

#5
Thanks, I got it going again.  Looks like I had a bad connection on the ground pin on the connector plug and with all my fiddling it started working, soldered it and now works again.

Still odd though that the brake lights only work with ignition ON :-\ ?
Daniel
1977 450 SEL 6.9 - Astralsilber

mrkozzy

Quote from: daantjie on 20 June 2022, 07:59 PMStill odd though that the brake lights only work with ignition ON :-\ ?

I'll confirm that mine is the same.  Ignition "on" brake lights work.  No brake lights without the key being turned.

The tail and head lights work at any time. No key needed. 
Its only the brake, reverse and indicator that need to be powered up.
MrKozzy

daantjie

Quote from: mrkozzy on 21 June 2022, 06:50 AM
Quote from: daantjie on 20 June 2022, 07:59 PMStill odd though that the brake lights only work with ignition ON :-\ ?

I'll confirm that mine is the same.  Ignition "on" brake lights work.  No brake lights without the key being turned.

The tail and head lights work at any time. No key needed. 
Its only the brake, reverse and indicator that need to be powered up.

Cool thanks  8)
Daniel
1977 450 SEL 6.9 - Astralsilber

UTn_boy

The brake lights coming on only when the ignition is on is something Mercedes has been doing since about 1960.  It's normal. 
1966 250se coupe`,black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3,papyrus white/dark red leather
1975 450se, pine green metallic/green leather
1973 300sel 4.5,silver blue metallic/blue leather
1979 450sel 516 red/bamboo

daantjie

Quote from: UTn_boy on 21 June 2022, 03:42 PMThe brake lights coming on only when the ignition is on is something Mercedes has been doing since about 1960.  It's normal. 

Thanks Aaron good to know cheers.
Daniel
1977 450 SEL 6.9 - Astralsilber