Author Topic: Light idle stumble on the 6.9  (Read 94 times)

daantjie

  • W116 Addict
  • ****
  • Posts: 1,715
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Light idle stumble on the 6.9
« on: 14 July 2019, 06:22 AM »
Hi guys

Weird one IMHO.  Since changing out the exhaust on my 6.9 I am noticing the odd "puff-puff" type sound out the exhaust pipe out the back.  It seems to coincide with a very light idle shake of the motor, I would say once every 2 seconds or so.  Otherwise the idle is very smooth so I do not think this is due to vacuum leak ????  From memory I think the sound out the pipe was always there but now for sure more pronounced with the new exhaust setup.

So it reads as a random misfire, so I am inclined to think electrical? Motor pulls like a train otherwise with no hesitation.

Thoughts?

Cheers
« Last Edit: 14 July 2019, 07:38 AM by daantjie »
Daniel
1977 450 SEL 6.9 - Astralsilber

jjccp

  • Classic
  • **
  • Posts: 153
  • Location: Detroit, Motor City, USA
Re: Light idle stumble on the 6.9
« Reply #1 on: 14 July 2019, 08:17 AM »
I just had my 6.9 fuel distributor and warm up regulator rebuilt and reinstalled along with new injectors. I originally had a hot start problem. Wow, what a difference that made. Engine runs and starts very nicely. The only thing I notice is a small hesitation from idle when accelerating, then it takes off. My mechanics (old guys with German accents) said it's a very common issue. I'm happy to live with it.
1977 280 SE
1979 6.9 #6846