News:

www.W116.org
By the people, for the people!

Main Menu

Intake boot at throttle butterlfy - re/re a pain?

Started by daantjie, 10 June 2022, 11:53 AM

daantjie

Hi guys

I am clearly bored and looking at stuff to "fix" 8)   The large intake boot beween the intake and throttle butterfly on my 6.9 looks mighty tired.  Also, I see a second band clamp below the top one, which does not look spec to me, so I can only guess a previous tech thought it a good idea to add another clamp, which of course will lead to shenanigans to get off :o Not sure why they would do this but I digress...

I checked the W126 boards and it looks like the top band clamp has some old school type ratcheting screw so you can tighten from above.  Some folks state that this design is a PITA to replace so likely I think a large enough hose clamp will do the jobby, no?  Some guys even use a BMW M3 clamp on there, uhm no...

Any folks done this jobby with success recently?  In my experience this looks like a "simple" job, but this could lead to a nightmare ::)

Cheers
Daniel
1977 450 SEL 6.9 - Astralsilber

Jan S

daantjie,

you are digging into my late fall job. I plan to take of the entire air intake and replace all the rubber parts and gaskets. A US 6.9

I'm in discussions with Elring about the two air intake gaskets left and right.

I haven't studied the area you are addressing in detail. Look forward to following this thread.

Sorry I can't help you at the moment ...
1975-mod W116 450 SE with 6.9 engine

daantjie

Haha maybe I'll just wait for you to do it first  ;D
Daniel
1977 450 SEL 6.9 - Astralsilber

Randys01

YES I'VE DONE IT AND IT'S A REAL PITA!
You will need to think about how to get around the top band...you will need a top drive.

s class

That vertical drive band is also used on the 4.5.  Getting it off isn't too much of a problem, but the success rate of trying to reuse it isn't great.


[color=blue]'76 6.9 Euro[/color], [color=red]'78 6.9 AMG[/color], '80 280SE, [color=brown]'74 350SE[/color], [color=black]'82 500SEL euro full hydro, '83 500SEL euro full hydro [/color], '81 500SL

daantjie

#5
I did this jobby and it was not too bad actually.  Yes that "corned beef can" type clamp is a bit odd but I was able to reuse mine.  I had to wind out the band and snip off some at the end as it was a bit mangled, then just rewound it back onto the buckle.  The trick is get it to "bite" at the start, then it's just a matter of getting the loop big enough to just slip over the boot and then tighten in situ and lock down the toothed "brake" section.  If you do it right you need very little tightening for it to grab the boot nice and tight.  Funny that mine was "Beru" brand, same as the plug wires and stuff.
I also applied some silicone grease to the whole clamp and buckle/screw so that the whole thing would slide on itself as well as on the rubber boot, which I think is key to get an even clamp. 
Daniel
1977 450 SEL 6.9 - Astralsilber