Author Topic: Help Please 1974 280SE  (Read 362 times)

Dingo

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Tasmania Australia
Help Please 1974 280SE
« on: 09 December 2020, 02:15 AM »
Hi All
I have been reading all the excellent info on this forum but unfortunately i am unable to find a issue similar to mine. I am a amateur but unable to find anyone locally that is happy to have a look at it. I have inherited a 1974 280SE that had been sitting in a shed for 25 years. After cleaning out the fuel tank away it went. It has had a visit to the garage to have all the fluids,filters plugs and leads(except the coil lead as it was different) changed. It was running fine all be it had a high idle. On my way home from the garage it suddenly cut out. I towed it home and soon as i got home away it went again. I then drove it the next day for about 20 minutes then it cut out again. Since then i am unable to get any spark at all. The fuel pump is running and pumping fuel but just no spark. I have tried replacing the coil (second hand) ICU unit (second hand) and the points(new) and still nothing. I have 12v to the coil but as soon as i connect it up to the positive side of the coil with the brown wire that goes to the ICU unit it goes back to 0 volts. Is this suppose to happen? or is the ICU unit cutting the power for some reason. Sorry for the poor descriptions as i stated i am an amateur but would love to get this beautiful car going. Thanks in advance for any help much appreciated

daantjie

  • W116 Addict
  • ****
  • Posts: 2,169
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Re: Help Please 1974 280SE
« Reply #1 on: 09 December 2020, 05:53 AM »
Welcome here.
I would not replace an old coil with a used one personally.  They are not that pricey and can be the source of many an electrical gremlin.  Another cheap fix is a new cap and rotor, seeing as you have already replaced some of the components, might as well go the whole hog and swap them out too.
Cheers
Daniel
1977 450 SEL 6.9 - Astralsilber

Dingo

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Tasmania Australia
Re: Help Please 1974 280SE
« Reply #2 on: 09 December 2020, 01:48 PM »
Thanks for your reply the reason I bought second hand is I was struggling to find new are you able to point me in the direction where I can buy new
Thanks again

daantjie

  • W116 Addict
  • ****
  • Posts: 2,169
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Re: Help Please 1974 280SE
« Reply #3 on: 09 December 2020, 02:45 PM »
Part number looks to be 0001582803.  If you do an online search you should be able to find online sellers/vendors who will ship to you.
Or you can try rockauto, or autohausaz not sure if they ship internationally and shipping will likely suck.
Try local ebay as well or ebay.com.au
Daniel
1977 450 SEL 6.9 - Astralsilber

mrkozzy

  • Classic
  • **
  • Posts: 204
  • Only a Benz will do!
  • Location: Melbourne Australia
Re: Help Please 1974 280SE
« Reply #4 on: 09 December 2020, 05:59 PM »
Hi Dingo.


Try this link             https://automotivesuperstore.com.au/afi-c9139

This is one of a few sources. I'm sure there is some one close to you that will have it available.
MrKozzy

Dingo

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Tasmania Australia
Re: Help Please 1974 280SE
« Reply #5 on: 15 December 2020, 01:43 AM »
Thanks mrkozzy this is the plate so will that coil suit
Cheers