News:

Location, Location, Location.
Please add your location to your profile. It will help others to help you!

Main Menu

Climate Servo Alternatives

Started by sutekh, 22 March 2022, 06:25 PM

sutekh

Hello! Second post having recently acquired a '79 300SD. The seller of my vehicle claimed the climate control and specifically heater was 100% functional, but to my disappoint (if not surprise), that's not the case. I only get cold air regardless of the temp wheel position or buttons pressed. I also don't hear the servo park after shutdown. I'll verify, but for the purpose of this post I'm going to assume it's seized.

I have the utmost respect for those who work hard to keep their vehicles 100% original. I have vehicles in that category myself, but that isn't my intent here. Frankly stated and qualified by personal experience with two different r107s, the Chrysler-derived OE ACCII servo is a terrible design. I have no desire to spend money replacing / maintaining one.

So... Of the two commercially available options I'm aware of, which have forum members who've installed them had good experiences with?


I believe the later was more recently developed by forum member @Blue300SD. Do both provide full, original functionality? Any reliability concerns one vs. the other? Do they install without butchering original wiring and vacuum plumbing (I'd like to be able to re-install an OE servo if necessary)?

Thanks in advance for any insights!

UTn_boy

Anything offered aftermarket will require butchering something to some degree.  In addition, if any of the vacuum actuators have ruptured diaphragms, nothing will work regardless of what system is on the car. 

I have two W116 cars with this Chrysler system on them.  I repaired both of them at the same time 7-8 years ago, and for 7-8 years of regular use I have had zero problem with the original system.  I don't understand the hate these systems get.  If done correctly, and the amplifier is replaced in unison with the servo, then there are usually no hidden issues to worry about.  And no, they system isn't the best that could have been utilized, but it works well when repaired correctly.  If anything, the air volume output is quite anemic, but so was the output volume of the early systems that were manually controlled.  But that's just the nature of the beast. 

In light of my aforementioned commentary, I can't condone anything aftermarket.  While I have no experience with them, they may work fine for all I know.  I just can't fathom reinventing the wheel for the sake of falling short on thoroughness when attempting to repair the original system.   
1966 250se coupe`, black/dark green leather
1970 600 midnight blue/parchment leather
1971 300sel 6.3, papyrus white/dark red leather
1971 280sel Black/black leather
1973 300sel 4.5, silver blue metallic/blue leather
1979 450sel 516 red/bamboo

daantjie

Indeed the system does make some folks want to drop kick the thing, but I find the ACC system kind of weirdly quaint and when it does work it actually does an adequate job of heating and cooling.  Remember too that modern HVAC system are of course vastly superior to 70's tech, so taking this into account I would agree with Aaron that any modern hack will likely not be much better in terms of performance.  Vacuum leaks are usually the first port of call as the ACC system is heavily dependent on vacuum so if you have leaks then it won't work at all or you will get sporadic operation which is of course even more frustrating :o
Daniel
1977 450 SEL 6.9 - Astralsilber

sutekh

Thanks for the insights! I'm still anxious to hear from anyone with either aftermarket alternative installed.

With respect to other's opinions, I will not be investing time / money into the OE servo system & amplifier on this car. I've rebuilt servos on those aforementioned r107s and seen very plainly where their faults lie. While they may work adequately when new or after rebuild, the complex clockwork of rotating vacuum seals and coolant passages given the material science of the day just isn't a recipe for reliability--hence the reason I believe they get that hate and generally don't work on cars not meticulously maintained and enthusiast owned.

Good news is that I've put my MightVac to the actuator lines, and everything seems to be exercising properly and holding vacuum. I also believe, having looked at the install docs for each modern alternative, that I should be able to install either without butchering anything. Some hoses will need to be re-routed or extended and wires jumpered, but I don't see that anything needs to be cut, drilled, or otherwise permanently modified.


Malpaso44

I purchased 2 of the UT units years ago. They work great and you can install them quite easily.
Some are born great, some achieve greatness and some have greatness thrust upon them.

john erbe

Likewise, I've got the UT unit on my 6.9. Works great.

john erbe

Likewise, I've got the UT unit on my 6.9. Works great.

JeffCullen

First of all Sutekh, congratulations on your lovely example and welcome.

I have the Hamilton setup in my car. It works Just Fine and is easy to revert - there is no cutting or hacking of factory wiring or systems. I'm into electronics and I like his kit - the quality is good.

The only thing I don't love about it is that when you have the climate control off, or you turn the car off, the W201 vacuum-controlled water valve these systems use opens up, allowing hot water into the heater core. When I get back into the car 10-15 minutes later and want cool air or A/C, I have to accept a brief sauna.

I must confess - I have never owned one of these with a working servo. Does the "parking" do the same - the servo parks in the open position?

The design choice makes sense from a failsafe perspective... but I still hate the hot air blast!

I got unlucky and my W201 valve failed within two years... cheap part, bought another off FCP Euro, easy fix.
1979 300SD #6680 - Astralsilber - 146,000km