News:

www.W116.org
All about the Car!

Main Menu

Central locking troubleshooting and repair

Started by raueda1, 08 April 2021, 12:24 PM

raueda1

Quote from: ptashek on 14 April 2021, 12:23 PM
Quote from: raueda1 on 14 April 2021, 11:27 AM
The bad: The line to the trunk reservoir seems to leak.

I'm assuming you've plugged it at the reservoir end, before testing? Could be just the grommet otherwise.
I did.  I also inspected the grommet, which seemed fine - properly pliable, not hardened/cracked/etc.  The tank itself holds vacuum fine (using another tube).
-Dave
Now:  1976 6.9 Euro, 2015 GL550
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0

raueda1

I've got progress (kind of) and annoyance to report.  Initially the new door switch seemed to fix everything.  But it was short lived, it just worked for a couple days.  Then it wouldn't hold a vacuum overnight.  WTF??  >:( >:( >:(

I went back to it and retested everything repeatedly.  It turns out that the NEW switch went bad after just a couple days of use.  The old switch was completely shot, it wouldn't hold a vacuum at all.  The new one loses vacuum after an hour or so, a kind of slow leak.  But it's still a leak.  I'm taking it up with the vendor.  Hopefully they'll make good on it by sending me another one.  I'll report back on the outcome.  Nothing ever gets easier.....   :-\
-Dave
Now:  1976 6.9 Euro, 2015 GL550
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0

raueda1

Success.  The vendor (AutohausAZ) immediately replaced the bad vacuum switch without drama or other issues.  I've had nothing but great service with these folks, but never had to do a return before.  Highly recommended.  The system now seems to hold a perfect vacuum far better than MB's leakdown spec.  Happy car!
-Dave
Now:  1976 6.9 Euro, 2015 GL550
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0