News:

www.W116.org - By the people, for the people!

Main Menu

Blower motor options / heater stuck on

Started by Jenno1981, 23 June 2023, 06:41 AM

Jenno1981

Hi guys,

I've got an AC blower motor/fan gone (tried 12v direct, clean out and even 'hitting the dash').

Options? Buying 2nd hand seems problematic.

Also, heater stuck on which I remember reading a common issue, just can't find any of the threads. Would appreciate advice there as well.

Cheers
Jenno
Melbourne, Australia
1978 450SEL - Runs/Registered
1978 280SEL - Not running/Project
1999 ML430 - Daily

sutekh

Can't help with the blower motor, but the heater stuck on sounds like a failed servo. Unfortunately, this is a very common (and expensive) problem for vehicles with the later automatic ACCII climate control system.

Purists may prefer to continuously replace / repair the servo unit and amplifier, but its overcomplicated design is so inherently flawed (blame Chrysler, not MBZ) that I don't think it's worth the hassle. Modern microcontoller-based electronic alternatives are available from Hamilton or Unwired Tools, and should solve your problem permanently (assuming you don't have other issues with vacuum or electrical wiring).

Jenno1981

Thanks Sutekh, I have the old manual climate control not the auto. I found out it uses a vacuum valve in the engine bay that fails and defaults to the 'on' position. I turned it off manually and I'll come up with something...

Blower Fan - bit the bullet and got a 2nd hand. See how long it lasts. Turns out my old one had worn down bushes, I see MercedesSource sells a bushes kit, any reviews on that here?
Melbourne, Australia
1978 450SEL - Runs/Registered
1978 280SEL - Not running/Project
1999 ML430 - Daily

rumb

Blower fan, there is option of this one:
https://www.autohausaz.com/pn/0008359802

Is this the valve?
https://www.ebay.com/itm/354890538523

It's NLA, but I remember a couple of years ago you could find aftermarket ones for very little.
Dont know if the ones offered now are NOS or just a rip off.

'68 250S
'77 6.9 Euro
'91 300SE,
'98 SL500
'14 CLS550,
'16 AMG GTS
'21 E450 Cabrio

Jenno1981

Thanks Rumb! Legend.

I've locked away that Uro reference if my new old Blower packs it in.

I'll have a hunt around for the heater valve. Saying that, haven't had a go at fault-finding so also check that off.

Cheers,
Jenno
Melbourne, Australia
1978 450SEL - Runs/Registered
1978 280SEL - Not running/Project
1999 ML430 - Daily

Rolo

When there is bad vacuum leak, FSM says unit goes to full hot.

As posted in another thread, I'm having a lot of issues with Unwired Tools  Shop and I both are trying to get resolved.   On paper sounds like a great unit at a lower price.  For starters, you lose the lowest fan speed setting, which if I get mine to work, will bother me.  I like the lowest fan speed.

If I could do over, I would just rebuild by old unit whenever it fails.