News:

www.W116.org
All about the Car!

Main Menu

6.9 starter solenoid

Started by nathan, 22 September 2022, 10:18 PM

nathan

Hi guys,

my 6.9 starter was playing up so I swapped it out.  The 'old' one im told needs a new solenoid.  Would anyone be wise enough to have a Bosch part number or advise on where to purchase?
the auto electrician suggested part number 0331 303 021 but I just want to confirm before I waste money!

regards
Nathan
1979 116 6.9 #6436
2018 213 e63
2011 212 e63
2011 463 g55
2007 211 e500 wagen
1995 124 e320 cabriolet
1983 460 300gd
1981 123 280te

daantjie

Yup that's the right part# for the solenoid.
Daniel
1977 450 SEL 6.9 - Astralsilber

raueda1

Quote from: daantjie on 23 September 2022, 01:30 AMYup that's the right part# for the solenoid.
Was that a kind of "universal" solenoid for late 70's-early 80's MB's?  It seems to turn up online as for W123's etc.
-Dave
Now:  1976 6.9 Euro, 2015 GL550
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0

daantjie

Quote from: raueda1 on 23 September 2022, 11:27 AM
Quote from: daantjie on 23 September 2022, 01:30 AMYup that's the right part# for the solenoid.
Was that a kind of "universal" solenoid for late 70's-early 80's MB's?  It seems to turn up online as for W123's etc.

Yes they are used across multiple starters/models.
Daniel
1977 450 SEL 6.9 - Astralsilber

raueda1

Thanks Daniel, I'll soon be following Nathan's example.  My starter often just spins when engine is cold but seems to always engage on the second try.  When engine is warm it only rarely spins.  Should I be looking at anything other than the solenoid?  Cheers,
-Dave
Now:  1976 6.9 Euro, 2015 GL550
Before that:  1966 230S, 1964 220SE coupe, 1977 Carrera 3.0

rumb

I seem to recall loose ball bearing to deal with if you remove and clean the bendix.
'68 250S
'77 6.9 Euro
'91 300SE,
'98 SL500
'14 CLS550,
'16 AMG GTS

daantjie

Indeed this is a finicky job.  I had a post a while ago when I redid mine.  I also bought a refurbished one off ebay which I chose to install instead.  Works flawlessly, touch wood.
The one I refurbished tested fine on the bench so I think I did an OK job but it's such a prick of a job getting it in and out that I opted for the Bosch refurbed one instead for installation.
Daniel
1977 450 SEL 6.9 - Astralsilber

daantjie

#7
Here is my old post:

https://forum.w116.org/mechanicals/odd-intermittent-starter-noise/30/

To be honest this post is a blur, it was during Covid peak so I think I was very dazed and confused 8)

Just some further update to my saga.  Indeed after I dropped in the refurbed unit, it did not go all peaches and cream in that the "laziness" of the bendix to pull back in was indeed a problem and would occasionally cause the bendix gear to get rubbed by the ringgear with a bad noise of course.  So I had to pull it out again and this is when I decided to stop buggering around with my old one and buy a Bosch refurbed one, which has to date performed flawlessly.

I did later on replace the solenoid on my old one, and the bench test was perfect, so I have to conclude that in addition to the sticky bendix initially, I also ended up with a "lazy" retract, perhaps due to the newer less worn components and tighter clearances?  I can only guess, but the new solenoid cured this problem, and it now snaps back very crisply, so indeed you need to ensure that it throws out rapidly and also retracts rapidly, otherwise you will be stuck again.

Sorry for rambling here, hope this helps ;D
Daniel
1977 450 SEL 6.9 - Astralsilber