News:

www.W116.org
All about the Car!

Main Menu

6.9 K-jetronic rough and high idle cold start

Started by Jan S, 10 June 2021, 05:36 PM

hamidagha

Deleted as I posted to wrong thread! Sorry

Jan S

Quote from: johnnyw116 on 11 March 2022, 05:41 AMwould an hose adaptor solve the reduction of the hose ?
something like this :  https://www.ebay.co.uk/itm/122049247077


Perfect - thanks a lot!!!

Order already placed.
1975-mod W116 450 SE with 6.9 engine

Jan S

1975-mod W116 450 SE with 6.9 engine

johnnyw116

Quote from: Jan S on 13 March 2022, 02:49 PM
Quote from: johnnyw116 on 11 March 2022, 05:41 AMwould an hose adaptor solve the reduction of the hose ?
something like this :  https://www.ebay.co.uk/itm/122049247077


Perfect - thanks a lot!!!

Order already placed.
i hope it solves the problem , it's hard to get stuck at such an simpel part like a hose 
JohnnyW116

Jan S

All required parts for the "self-designed" "100-hose" are on their way. Fingers crossed it will all fit  :-\  We'll know in 2-3 weeks (shipping takes so long  :'(  )

First part has arrived - the 3-way hose splitter! One down - many to go !
1975-mod W116 450 SE with 6.9 engine

Jan S

Quote from: johnnyw116 on 14 March 2022, 07:44 AM
Quote from: Jan S on 13 March 2022, 02:49 PM
Quote from: johnnyw116 on 11 March 2022, 05:41 AMwould an hose adaptor solve the reduction of the hose ?
something like this :  https://www.ebay.co.uk/itm/122049247077


Perfect - thanks a lot!!!

Order already placed.
i hope it solves the problem , it's hard to get stuck at such an simpel part like a hose 

That hose almost drove me crazy! We'll see, I'm not at the goal line yet.
1975-mod W116 450 SE with 6.9 engine

daantjie

Well if all goes well you can make a very limited side business to 6.9 owners ;D
Daniel
1977 450 SEL 6.9 - Astralsilber

Jan S

Quote from: daantjie on 14 March 2022, 10:25 AMWell if all goes well you can make a very limited side business to 6.9 owners ;D

 :)  LOL

I will post a pic with specs when the hose is complete.

1975-mod W116 450 SE with 6.9 engine

Jan S

I have been working on a "custom design" for the "100-hose". It took me 5 weeks and a few attempts.

The challenge is space constraints on top of the air intake and parts delivery time.

I believe this solution will work (see pic). Final assembly tomorrow. Knock on wood.

I need the car for a road trip in a week from now, hence the design of the lower left part of the hose is preliminary (marked with the red rectangle). I will replace that section with one piece oil-resistant silicone hose, custom made (see drawing), in a few weeks time. That means $$$, but it was very hard to find a suitable solution given the space constraints and required reduction. In the end I decided to pay $$$ to get the car on the road.

Tomorrow is the day ....
1975-mod W116 450 SE with 6.9 engine

Jan S

It worked - the self-made "100-hose" was installed yesterday, finally. Fired up the engine today. All fairly good, but idle is still high (900 rpm when warm). I guess it's a vacuum leak, somewhere.

Summary of what I have done last 6 months:
- replaced thermostat
- replaced engine coolant temp sensor
- cleaned idling house
- replaced all rubber boots and vacuum hoses around idling house and WUR
- replaced "100-hose"
- cleaned and tested aux air valve
- new injectors incl. rubber seals

The plan is to do a smoke test .... I assume there are some leaks under the air intake.

The chase for leaks continues, but first a road-trip in a weeks time.
1975-mod W116 450 SE with 6.9 engine