Author Topic: 6.9 Coil wire questions  (Read 75 times)

daantjie

  • W116 Addict
  • ****
  • Posts: 2,053
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
6.9 Coil wire questions
« on: 01 October 2020, 11:42 AM »
Hi guys

I got a Karlyn/STI set of cables a while ago, and they seem to work OK, however the coil wire is way too long, and also the connection on the coil is very loose ???  Looking at the EPC is looks like the coil wire is sourced separately, but it does not show a boot/connector on the distributor side ???  I would think that the iffy connection on the coil cannot be good?

Here is wire from ebay listing, shown on the EPC, blue in colour with no connector on one side:

https://www.ebay.com/itm/Ignition-Cable-Mercedes-m-116-A1161506018-Genuine-Brand-New/223386390585?hash=item3402ddd039:g:JwUAAOSw8KRcYtC4

Or...perhaps have the sides mixed up, so the "loose" side (at coil now) will be tight at the distributor?

« Last Edit: 01 October 2020, 11:50 AM by daantjie »
Daniel
1977 450 SEL 6.9 - Astralsilber

w116john

  • Classic
  • **
  • Posts: 291
  • Location: ireland
Re: 6.9 Coil wire questions
« Reply #1 on: 01 October 2020, 02:34 PM »
hi

i bought set of those leads years ago they were all i could find at the time, for my 450 and had the same responce as you. the leads worked fine but i was unhappy with the coil lead, i felt it was very loose, so i bought another one with the more secure fitting to the coil.

had them on a few years worked fine, then replaced rotor, cap and leads with Bosch / beru  which are still on the car.

regards

john




daantjie

  • W116 Addict
  • ****
  • Posts: 2,053
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Re: 6.9 Coil wire questions
« Reply #2 on: 01 October 2020, 03:02 PM »
Thanks yes looks like I'm going to find another coil wire.
Cheers
Daniel
1977 450 SEL 6.9 - Astralsilber