Author Topic: 280SE D jet loses power randomly while accelerating  (Read 223 times)

daniel.lai@archTIS.com

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Australia
280SE D jet loses power randomly while accelerating
« on: 30 April 2019, 09:13 PM »
Help!

My 1975 280SE D Jet randomly loses power when accelerating. I have changed the ICU and MAP Sensors, checked the injectors and swapped the ECU all to no avail. It has been sent to two different Mercedes mechanics neither knows what the hell is going on?

It is random and hard to replicate but consistent enough to make it dangerous and frustrating to drive.  Has anyone got any ideas?

Dan

Alec300SD

  • Classic
  • **
  • Posts: 130
  • W116 Enthusiast
  • Location: San Mateo, CA
Re: 280SE D jet loses power randomly while accelerating
« Reply #1 on: 30 April 2019, 10:49 PM »
Binding, sloppy throttle linkages?
Intermittent blockage of fuel tank strainer by a foreign object?
Excessive water in the fuel?
Dried out fuel hoses?
Poor fuse connection to fuel pump?
Worn wires/connectors to fuel pump?
Bad check valve electric fuel pump?
Worn brushes in electric fuel pump?
Excess varnish on vanes of fuel pump impeller?
79 W116 300SD 'Stormcloud' new as of 10/22/2017
78 W116 300SD 'Desert Rose' new as of 01/26/2014
83 W126 300SD 'Rena 2.0' with engine from 82 W126 300SD Rena' (SOLD and crushed 11-20-2017)

daniel.lai@archTIS.com

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Australia
Re: 280SE D jet loses power randomly while accelerating
« Reply #2 on: 01 May 2019, 06:03 PM »
Thanks will get on to it.

daniel.lai@archTIS.com

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Australia
Re: 280SE D jet loses power randomly while accelerating
« Reply #3 on: 01 May 2019, 06:04 PM »
I have also replaced the fuel pump.

gf

  • Classic
  • **
  • Posts: 457
  • Location: hobart
Re: 280SE D jet loses power randomly while accelerating
« Reply #4 on: 03 May 2019, 05:20 PM »
Does the motor skip and splutter? Could be an electrical fault.check the connections and lines in good condition, HT leads, distributor cap clean and seated right? Points not burned out? Rotor button in good shape. How old is the coil? Are the ballast resistors old with any rust or cracked insulation? Are the fuses and fuse box connections old and tarnished?  All these things have given these issues to my car at some time or other over the years. These are OLD OLD cars.

daniel.lai@archTIS.com

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Australia
Re: 280SE D jet loses power randomly while accelerating
« Reply #5 on: 05 May 2019, 10:47 PM »
Thanks I'll go over the connections, has a new Disti. I've also checked the coil. Resistors are old, I'll replace them and see what happens.

Mergyver

  • Enthusiast
  • *
  • Posts: 63
  • W116 Enthusiast
  • Location: NJ
Re: 280SE D jet loses power randomly while accelerating
« Reply #6 on: 09 May 2019, 02:07 PM »
Hi Daniel,

I have a 74 450SEL with D-Jet. I have had a problem where the engine would sputter occasionally when I move the gas pedal. So for example cruising down the highway I might lift a bit for slower traffic or press a bit to pass someone. The engine would sputter for a second.

I traced it down to a worn throttle position switch. There is a printed circuit board that acts like a rheostat and wears down. There is a guy that has new boards for sale on ebay. They are pretty cheap. I think I googled "w116 TPS" and found him.
1974 450SEL
1979 300SD
1989 560SL
2005 E320 CDI Recently deceased

daniel.lai@archTIS.com

  • Newbie
  • Posts: 5
  • W116 Enthusiast
  • Location: Australia
Re: 280SE D jet loses power randomly while accelerating
« Reply #7 on: 09 May 2019, 04:20 PM »
Thanks Mergyver

I have thought of that but didn't really know how to test it without replacing it. When I hold the the accelerator at the same point it is still not constant. When I increase acceleration past the point it gets worse and when I back off completely it mostly recovers.

Dan

Mergyver

  • Enthusiast
  • *
  • Posts: 63
  • W116 Enthusiast
  • Location: NJ
Re: 280SE D jet loses power randomly while accelerating
« Reply #8 on: 09 May 2019, 07:52 PM »
The guys name on ebay is Peuver. I believe his email address is  r17ttok@gmail.com He is also active on the Porsche D-jet systems. You may want to get his thoughts
1974 450SEL
1979 300SD
1989 560SL
2005 E320 CDI Recently deceased