Author Topic: 1st Gen Mercedes ACCII Climate Control Servo: Less Expensive Replacement Option  (Read 3111 times)

Blue300SD

  • Newbie
  • Posts: 9
  • W116 Enthusiast
  • Location: Raleigh NC
Hey Guys-

I am copying this thread that I posted on the 380SL forum. I recently owned a 1980 300SD with the ACCII system, and now own a 1981 380SL with the same climate control system. Both had failed Chrysler servos, so I made this replacement kit:

I'm starting a new thread regarding the climate control servo replacement I developed with my coworker/ friend in Stuttgart, Germany.

As you probably know, the first gen climate control system uses an amplifier to control a very complicated servo under the hood. The servo/ amp controls four main functions: letting water into the heater core, controlling the fan speed based on the user inputs, and opening the leg and center vents based on user inputs of hot/ cold/ defrost.

The servo failed in my car, and I thought Unwired Tool's price of $600-800 was ridiculous based on my knowledge of electronics and what parts make up their replacement kit.

Thus, I reached out to my friend in Germany and we developed our own using Mercedes and Chrysler documentation from the when the system was designed.

To install my unit is very simple. You remove the amplifier + servo and install a few bypass wires in the wiring harness (of the amp), a w201 chassis heater valve, and a tube in place of the return line from the servo. It took me about two hours moving slowly :)

My board plugs directly into the wiring harness that went into the servo. The microcontroller then receives the user inputs from the temperature selector wheel and sensors inside the car.

Additionally, my board uses three vacuum solenoid valves to accomplish the same goals of the old servo: 1) Controls Hot Water 2) Controls Leg Vents 3) Controls Center Vents. A circuit made up of four relays directs fan speed.

The vacuum lines from the servo connector plug into the three different solenoids, and one vacuum line plugs into a source (such as the reservoir). Thus, based on user controls, my software on the board tells each solenoid when to open or close, and also directs the relays. This replicates the original function of the cumbersome servo and amp.

I can sell my unit a lot cheaper than the OEM servo or Unwired Tools. Additionally, since it uses modern electronics there is no expensive risk of failure, as associated with the servo.

It will take about two weeks to manufacture for anyone interested. I’ll sell the whole kit with the w201 valve, vacuum lines, board, etc for $325 to anyone interested. I also plan to write up a little instruction manual and take some photos of the install on my car. You can PM me if you want to hear more/ get a kit! Thanks a bunch.

-Davis

Mattr

  • Enthusiast
  • *
  • Posts: 44
  • 6.9 in a 450SE
I would definitely be interested in seeing photos/a write up. My system is currently working, but I realize that it's a matter of 'when' and not 'if.'
1976 450SE 6.9 FrankenBenz (#2288?)
1977 450SEL 6.9 #2333

karmann_20v

  • Classic
  • **
  • Posts: 284
  • W116 Enthusiast
  • Location: Toronto, Canada
I would be interested once we get some feedback from people installing and using these. Do you intend to just have a single run and be done with it, or are you going to offer it indefinitely?

Harv

  • Classic
  • **
  • Posts: 388
  • W116 Enthusiast
  • Location: Pgh, PA
This sounds really interesting. My main gripe with my 116 is the heat and AC system is a nightmare.
1980 300SD
1983 240D
2000 E55 AMG

Blue300SD

  • Newbie
  • Posts: 9
  • W116 Enthusiast
  • Location: Raleigh NC
Thanks for your input and interest!

I am planning to take photos at the end of this week of the one I installed in my Mercedes 380sl. In the meantime, I've drafted up an "installation manual" of sorts. It isn't complete, as I plan to add photos, but it may help anyone who is curious get a better idea of how it works and where it hooks up. My coworker in Stuttgart and I battled very hard to make it integrate directly with the existing system, and not require any additional sensors/ parts. The manual is attached. I'd love your input on anything in the manual that is unclear/ not helpful!

Responding to Karmann, I am trying to decide right now whether to offer them indefinitely or just temporarily. I think if there's enough interest, I will continue to make them, as the bulk of the work was designing the board not soldering them together :)

Also responding to Karmann, and in general, I understand it's a "new product" so there should be some skepticism. For that reason, I am hashing out a warranty I want to offer. I have no issues standing by the boards, as I really splurged on the internal parts. For example, I am currently using medical-grade solenoids that alone cost $93 dollars per board I sell. What do you guys think about that? What would be an appropriate length warranty?

Please find below a photo of the initial board I was using for testing and the "installation manual."

karmann_20v

  • Classic
  • **
  • Posts: 284
  • W116 Enthusiast
  • Location: Toronto, Canada
Davis, thanks for responding to my questions. Please don't take this the wrong way, but when something is "too good to be true...", you know the rest. For that reason I personally wanted some real world feedback before committing. That being said, if what you say is true, more power to you! I would advise you to continue offering these, especially now that most of the R&D is done. Warranty is not as crucial to me (my W116 is intended to be a second summer cruiser), I am not sure about others but not too many of these see daily driver duty - maybe other members will chime in. Therefore, a reliable and trustworthy system that performs in a similar fashion to the OE unit is key. And going back to my initial statement, confirmation/feedback from 3rd parties using your system is very valuable, at least to me.

Diesel 617

  • Classic
  • **
  • Posts: 215
  • Location: Illinois
Woot woot! This is a project I am deeply interested in. For lack of proper words Fuck Chrysler and their shit servo system. If your telling me I can gut my 300SD of its deadly parasitic Climate Control system all while maintaining the original climate control panel and functionality, where do I sign?

May I suggest a short minuet video showing the system properly functioning? With a thermostat in the car to show the change in temperature.

Would also love to see how the system looks installed in the car (but as you said you are working on adding photos).

Come summer time I want this kit as long as it holds up and checks out.

Also is there an inline fuse installed for the aux. water pump? Would hate to see the board fried due to a faulty pump.

Thank you for letting us know about this development! Please keep us informed as to how it progresses!
X3 1980 300SD Blown Heads, trans -Retired
1980 450SEL Parted out
1980 450SEL to Diesel Parted Out
1979 280SE Euro Spec Cloth Seats: Needs Rebuilt head and WUR
1979 300CD Daily Driver


Inventory of w116 Parts
https://www.ebay.com/usr/vintagepartsandstuf

Zaxxon

  • Classic
  • **
  • Posts: 137
  • Ihr guter Stern auf allen Strassen.
  • Location: CT, USA / Germany
I am in the process of getting my A/C working again before summer, and would LOVE to replace that pesky servo by then! The board looks great, and from what I can see in the pics definitely awesome quality! Will you be supplying a housing for the board with it? I was actually thinking about doing something along those lines with an Arduino or other microcontroller myself by then, but to be honest, all the trial and error and such is already done with your project, and it will definitely save some time!

--Zax
---
Mercedes: '99 CL500, '86 500SEC, '96 SL500, '06 R500, '02 ML320, '78 450SEL
Porsche: '80 928S 5-Speed, '86.5 928S RogerBox '86.5 928S 5-Speed, '83 944
Others: '84 Callaway Alfa Romeo GTV6, '83 Tiara, '87 FZ

Blue300SD

  • Newbie
  • Posts: 9
  • W116 Enthusiast
  • Location: Raleigh NC
Good Evening-

Thanks again for your suggestions!

Responding to Zaxxon, I have posted a photo below of the climate control "brain" which is the physical box that will plug in place of the servo for the wiring harness and vacuum controls. I plan to supply my board as shown in the box, along with a heater valve from a W201 chassis, and all necessary hoses, wires, and connectors to make the swap.

Also, Diesel 617, I love your idea about a video with the thermometer to show it working. However, my car is at my vacation home in NC. I just left and was only able to get the video from the engine bay, that I have uploaded to youtube. The link is below. It shows my prototype board opening and closing the car's vacuum lines to control the heater valve, and thus regulate the cabin temperature. The data for opening/closing is based on the temp setting on the pre-existing user panel, combined with information from the cabin and outside temperature sensors.
https://youtu.be/vCFWV3DuDzs

When I get back to NC, I will make a video showing the temperature changing (please standby that won't be until summer time)! Hopefully, we will have promising reviews by then :)

From my design, I am not concerned about the water pump as I would be with the original servo + amp (other than that a failed water pump is not healthy for coolant getting into the heater core). If you review my "instruction manual," you'll find once you remove the servo amp, pins 7-8 are jumped. This provides a fused 12v to pin #4 inside the engine bay on the servo wiring harness which is the power for my board. Unlike the old servo, this is my direct source of 12v, so it will not be affected by a water pump failure. Thank you for your suggestion, and I am open to any more!  :D

I have done extensive testing over the past week on my '81 380SL with the 1st gen Auto Climate Control System, and I am confident in the technology. Now, I am putting together some of the final boards that I will proceed to bench test, once again. From there they will be good to go for anyone interested.
-Davis

daantjie

  • W116 Addict
  • ****
  • Posts: 1,673
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Whilst I applaud your efforts, I find that the boxed unit appears quite large to fit in the engine bay of larger engined 116's.  For example I would be surprised if you would be able to fit that sized unit into the bay of the 6.9.  The ACC unit is already a snug fit in there.  Just my 2c.
« Last Edit: 21 March 2018, 10:41 AM by daantjie »
Daniel
1977 450 SEL 6.9 - Astralsilber

Blue300SD

  • Newbie
  • Posts: 9
  • W116 Enthusiast
  • Location: Raleigh NC
Daantjie-

I really appreciate your warning there. I picked that housing to prototype my unit in the 380SL, without noting the size constraint differences between the R107 and 380SL. Luckily, the board is much smaller at 3.5” x 5” x 1.75” (including the valves in that height), so for the final shipment a much smaller housing will not be a problem.

This is why I posted to the forums first! You guys are the most knowledgeable and familiar with your specific models. Any other sizing/ installation issues that sound like they might pop up would be great to hear!

Take Care,
Davis

daantjie

  • W116 Addict
  • ****
  • Posts: 1,673
  • W116 Enthusiast
  • Location: Vancouver, BC, Canada
Daantjie-

I really appreciate your warning there. I picked that housing to prototype my unit in the 380SL, without noting the size constraint differences between the R107 and 380SL. Luckily, the board is much smaller at 3.5” x 5” x 1.75” (including the valves in that height), so for the final shipment a much smaller housing will not be a problem.

This is why I posted to the forums first! You guys are the most knowledgeable and familiar with your specific models. Any other sizing/ installation issues that sound like they might pop up would be great to hear!

Take Care,
Davis


Yup here you have come to right place for 116 info (and critique ha-ha).  There is simply no better resource on the planet ;D  Many other boards have 116 sections but this is the place to come to if you want the real deal.

Another mention on the 6.9 is that there is the leveling valve for the front suspension which is bolted onto the front sway bar, which in turn is bolted onto the firewall (US passenger side). It sits fairly deep into the engine compartment so it should not be an issue, but just another thing to consider.  For example if you want to work on the leveling valve on a US spec 6.9 you have to yank the ACC servo unit and all related hoses and auxiliary water pump out before you have ready access to the leveling valve and the hydraulic lines connected to it.

Cheers
Daniel
1977 450 SEL 6.9 - Astralsilber

xaliscomex

  • Enthusiast
  • *
  • Posts: 17
Will be closely following this post.  Own a 1979 300sd w116 and want to get rid of my Servo and amplifier

Blue300SD

  • Newbie
  • Posts: 9
  • W116 Enthusiast
  • Location: Raleigh NC
Hey Guys-

I was back at it this weekend doing some final testing. I finished fine tuning the heating/cooling intervals based on the user's input, and I also found a much more compact enclosure for the board that is made of aluminum. It is now smaller in every dimension than the Chrysler piece of junk-- and not to mention lighter for all of you trying to take your w116 to the track  ;) just kidding

Please see the attached photos of the new aluminum case.

I will continue testing the board and running it through the wringer this week. I want to go live with sales by the end of the week. Thanks

-Davis
 

1960mog

  • Enthusiast
  • *
  • Posts: 79
  • W116 Enthusiast
  • Location: Las Vegas, Nevada
Your ACC fix sounds very interesting.
If you are familiar with this older systems could you please describe what other components feed into your box and how to test them before installing your upgrade.
Things like temp wheel, temp sensor and vacuum pods.
Would your system work in a W123?
Would it be possible to mount the box inside the passenger compartment?
It would be more protected there, especially from the exhaust heat.

Thanks
78 6.9 #4084
79 6.9 #6669