Author Topic: 'Brake' light when parking brake applied?  (Read 2624 times)

chazchuzzlewitt

  • Enthusiast
  • *
  • Posts: 69
  • Location: London, UK
'Brake' light when parking brake applied?
« on: 05 July 2006, 03:00 PM »
my brake light doesn't come on in the instrument cluster when the parking brake is applied- I presume it's supposed to? I know the bulb is ok...
1980 W116 M110 280SE
1994 W124 OM606 E300D
----------------------------
1980 W116 M116 350SE-sold
1992 W124 M103 300E-sold

Denis

  • Classic
  • **
  • Posts: 334
  • Location: Paris
Re: 'Brake' light when parking brake applied?
« Reply #1 on: 06 July 2006, 04:43 AM »
When you turn on the ignition, the brake light will glow if the parking brake is set.

A friendly warning  ;D

Denis

Paris, France


chazchuzzlewitt

  • Enthusiast
  • *
  • Posts: 69
  • Location: London, UK
Re: 'Brake' light when parking brake applied?
« Reply #2 on: 06 July 2006, 06:06 AM »
ok... it does that- should it stay on until the brake is disengaged?
1980 W116 M110 280SE
1994 W124 OM606 E300D
----------------------------
1980 W116 M116 350SE-sold
1992 W124 M103 300E-sold

s class

  • W116 Addict
  • ****
  • Posts: 4,171
  • I'll keep the 116's, the rest can go
  • Location: Squeezing 3 W116's into a double garage
Re: 'Brake' light when parking brake applied?
« Reply #3 on: 06 July 2006, 06:20 AM »
The handbrake light shows if the ignition is on AND the handbrake is up.  If the ignition is off, of the brake down = no light.

'76 6.9 Euro, '78 6.9 AMG, '80 280SE, '74 350SE, '82 500SEL euro full hydro, '83 500SEL euro full hydro , '81 500SL

chazchuzzlewitt

  • Enthusiast
  • *
  • Posts: 69
  • Location: London, UK
Re: 'Brake' light when parking brake applied?
« Reply #4 on: 06 July 2006, 08:31 AM »
ok.. i must have a problem with a contact somewhere then as the light does not glow when the engine's running and the brake is set.
1980 W116 M110 280SE
1994 W124 OM606 E300D
----------------------------
1980 W116 M116 350SE-sold
1992 W124 M103 300E-sold

Denis

  • Classic
  • **
  • Posts: 334
  • Location: Paris
Re: 'Brake' light when parking brake applied?
« Reply #5 on: 06 July 2006, 10:49 AM »
You know chazch-machin  :P...if you forget the footbrake, that isn't too bad - the odour will warn you  :D

But on some cars, this warning light also tells you that your master cylinder level is too low - as in a leaky brake system - THAT is something you really want to know about.

Check the circuit.

Denis

Paris, France

Papalangi

  • Vintage
  • ***
  • Posts: 533
  • Location: Des Moines, WA USA
Re: 'Brake' light when parking brake applied?
« Reply #6 on: 07 July 2006, 01:10 AM »
On my '76 450SEL, the wire to the switch for the parking brake had come off.  That still didn't fix the light but filling the empty lamp socket with a new lamp did!  But then it stayed on all the time the ignition was on.  Turned out to be low on brake fluid.

Michael
1976 450SEL, 116.033  Sold it to buy a '97 Crown Vic.  Made sense at the time.
1971 250C, 114.023      Sad but true, it's gone to a new home.
1976 280C  Stolen by the City of Seattle, sort of.
1970 250/8, traded in on a 1993 Land Rover Disco

chazchuzzlewitt

  • Enthusiast
  • *
  • Posts: 69
  • Location: London, UK
Re: 'Brake' light when parking brake applied?
« Reply #7 on: 07 July 2006, 03:55 PM »
hmm, I guess the wire for the parking brake has come off for mine too. I double-checked and the 'brake' light doesn't come on with the ignition. The bulb is ok though as it came on once when the brake fluid level was low.
1980 W116 M110 280SE
1994 W124 OM606 E300D
----------------------------
1980 W116 M116 350SE-sold
1992 W124 M103 300E-sold

dizzyD

  • Enthusiast
  • *
  • Posts: 25
  • Location: southern california
Re: 'Brake' light when parking brake applied?
« Reply #8 on: 12 July 2006, 07:21 AM »
There should be a switch, I guess, right above the brake mechanism, maybe the switch is gummed up or bad, it shouldn't be that hard to remove and check it with an ohm meter.
 my .02c