News:

www.W116.org
All about the Car!

Main Menu

Weekend Wrenching

Started by alabbasi, 11 February 2006, 06:37 PM

alabbasi

Well, today was car day and I spent pretty much the best part of the day working on the 4.5 and the 6.9.

The first task was to swap the brown MB Tex interior for the blue leather seats that came from a 300SEL. The back seats came out easy enough but the front seats were a nightmare. For you 6.3 owners, you will see how four 10mm bolts can be such a pain in the A**. Getting the seat out is a little tricky but putting the seat back was where the real fun began. The trick here is to remove the spring at the bottom of the seat (used for the height adjustment) from its mount, and then re-attach it once the seat is bolted up using a hook.

I needed to replace the window channeling as they got bent up pretty badly during the paint job; I bought new channeling in a roll for the rear windows from Mr. Autos. When I installed this onto one of the rear doors, I began to have real problems rolling up the windows. Does anyone know of a trick to this? I left it for now, as I did not want to cause more damage then good.

Once the seats in the 4.5 were in, I moved on to the 78 (black) 6.9. The exhaust system is a real mess on this car. The manifolds are joined to a single pipe that runs all the way back to behind the rear wheels with no resonator. Because the system had no muffler, I am not willing to run the car for more then a few minutes, as I did not want to upset my neighbors. To provide a temporary fix, last week I went to AutoZone and bought a cheap universal muffler with a 2-inch pipe and an adaptor kit and bolted everything up. Once everything was bolted back up, I cranked the engine and found another hole in the left pipe just before it connects to the single pipe. This time I bought that cheap bandage kit (it only has to last a couple of weeks until I figure out what?s wrong with the rest of the car) and attempted to put it in place. So I put the car up on ramps and crawled underneath it and attempted to bandage the pipe. As soon as I touched that area of the pipe, it started to fall apart and I had another hole 

I wrapped up what I could and prepared to change the transmission fluid and filter. While under the car, I realized that the floor pan on the driver?s side is as rusty, if not worse then my other 6.9 was prior to the restoration. This must be a common problem as the right side floor was in good shape (like my other 6.9 was). It has been raining recently and I must have a massive leak from either the sunroof or windshields that cased a huge puddle in the rear foot well on the right side. This somehow started to drain when the car went on ramps.

I bought some of that Lucas automatic transmission stuff; it?s supposed to be the best snake oil on the market for transmissions . I drained the fluid and replaced the filter. That Lucas transmission fix is very thick, it took forever to empty the bottle (is this normal?). Once Lucas was in the transmission, I added some ATF and everything seemed fine.

I?m going to see if I can patch the exhaust system some more next week. If I can get it quite enough to drive it around the block and see if the transmission will make it up the hill I will take it to the Muffler shop and have them replace that single pipe with two, 2.5-inch pipes and use the original muffler. I also need to find a good used floor pan for this car, as MB no longer makes floors for the W116 cars.

This car requires a lot of work. What I can see doesn?t scare me, its what I can?t see that the most concerning. I think my approach however is solid as I am taking baby steps right now in the restoration process.

Tomorrow, Chris is coming by to help me with the electrics on my 4.5. The painters managed to take everything apart nicely but since putting it back together, I have no fog lamps, interior lamps, tail lights or side lights  He can also help me figure out how to make that window channeling work so that I can roll the windows up.
With best regards

Al
Dallas, TX USA.

Peter Anderson

Styria, you certainly did give me the advise on how to remove the front seats - though I have to admit I didn't get to do it in the end (and reading Alabbasi's description of the task I'm kind of glad I didn't!). The garage had both front seats out to do the repairs to the sills and floor, so it seemed silly for them to put the old knackered seats back in just for me to have to take them out again!

Mind you my wallet was sweated for the priviledge of not having to drop any physical sweat!

(and what do you mean foggy, it's beautifully sunny here - for the first time in about a week!!!)

alabbasi

With regards to DIY patch repairing  the muffler over towing the car to the muffler shop and having them make a new one.

Right now, I am having a bunch of other issues with the car, including poor running on start up and a slow transmission. It's very hard for me to diagnose these problems because I cannot run the engine for extended periods as it is too noisy and I need to consider my neighbors. But both the other symptoms can pretty much lead to a show stopper and turn this restoration project into a parts car (It really is a parts car right now). So ... Although I have full intention of having the exhaust system in the car replaced in the future. I would rather not spend that money on the car until I know that the car is mechanically sound. I can do a car with a weak engine and a strong body, or a car with a strong engine and a weak body. I can't do both  :)
With best regards

Al
Dallas, TX USA.

John Hubertz

Al....just wrap the hole with fiberglass cloth and use hose clamps....  You can use a big-ol radiator hose for the pipe to muffler connection.  Used to do it all the time.

John
John Hubertz
"When the going gets weird, the weird turn pro."
(Hunter S. Thompson) 

1977 450SEL (Max Headroom)

alabbasi

Thanks John, I'll take a stab at it next weekend.

Regards

Al
With best regards

Al
Dallas, TX USA.

John Hubertz

Al, one more thing on the trans....  I found the interior of my 107 flex hoses from the steel trans line to the radiator inlet and outlet were both deteriorating even though the outer cloth was intact.  If the return collapses it might cause part or all of your problem - and the 107 was in a storage lot 4 miles from where the 116 sat - maybe our cold winters do something to the rubber lining?

My 107 hoses were so bad one broke in half when I bent it about 1" to reconnect it....  it was just gone inside.

John
John Hubertz
"When the going gets weird, the weird turn pro."
(Hunter S. Thompson) 

1977 450SEL (Max Headroom)