Author Topic: W116 clock repair thread missing :-(  (Read 521 times)

ianc99

  • Enthusiast
  • *
  • Posts: 16
  • W116 Enthusiast
  • Location: Ireland
W116 clock repair thread missing :-(
« on: 15 June 2018, 05:53 AM »
I can see there was a thread for fixing W116 clocks here

https://forum.w116.org/mechanicals/does-your-clock-still-work/

But the link in this thread no longer works and I can't find the thread just searching here. 
Is there an old archive perhaps?

Squiggle Dog

  • W116 Addict
  • ****
  • Posts: 2,053
  • MBCA Member
  • Location: Surprise, AZ, USA
Re: W116 clock repair thread missing :-(
« Reply #1 on: 16 June 2018, 12:15 PM »
I believe the original poster changed his username, deleted all of his posts, and left for whatever reason.
Stop paying for animal cruelty and slaughter. Go vegan! https://challenge22.com/

1967 W110 Universal Wagon, Euro, Turbo Diesel, Tail Fins, 4 Speed Manual Column Shift, A/C
1980 W116 300SD Turbo Diesel, DB479 Walnut Brown, Sunroof, Heated Seats, 350,000+

ianc99

  • Enthusiast
  • *
  • Posts: 16
  • W116 Enthusiast
  • Location: Ireland
Re: W116 clock repair thread missing :-(
« Reply #2 on: 17 June 2018, 09:35 AM »
Well that's a bit antisocial!
Anyone have an alternative source or can tell me if the repairs to other clocks are similar (before I open mine up :-)

Alec300SD

  • Classic
  • **
  • Posts: 137
  • W116 Enthusiast
  • Location: San Mateo, CA
79 W116 300SD 'Stormcloud' new as of 10/22/2017
78 W116 300SD 'Desert Rose' new as of 01/26/2014
83 W126 300SD 'Rena 2.0' with engine from 82 W126 300SD Rena' (SOLD and crushed 11-20-2017)

ianc99

  • Enthusiast
  • *
  • Posts: 16
  • W116 Enthusiast
  • Location: Ireland
Re: W116 clock repair thread missing :-(
« Reply #4 on: 24 June 2018, 02:12 PM »
Thanks for that Alec