Author Topic: My 350se resto update  (Read 3356 times)

oscar

  • W116 Addict
  • ****
  • Posts: 4,043
  • Location: Riverina, NSW, AUSTRALIA
My 350se resto update
« on: 25 January 2006, 03:49 AM »
Well, got my 350 back yesterday from workshops and to say I'm impressed is an understatement.  In short '73 350se RHD 380,000km
Here's a list of some jobs done:

-replaced valve stem seals (2 were cracked, another 2 were squashed or pinched on one side)
-new timing chain (no idea if its ever been replaced)
-modulator valve on AT
-valve gaps adjusted
plus a few other things

The biggest difference I noticed was the power and fuel economy.  Huge improvement!  In comparison, the engine before used to labour when idling.  It was still responsive but nothing like now.  The motor hums, exhaust sounds better, the car sounds tight.

The transmission changes are smoother but the AT will need an overhaul eventually.

The smoke's gone as well.  Before, more often than not, the car would blow smoke on start-up.  Believed it was valve seals as compression on all cylinders were good but the AT was also losing fluid, quicker than what the slow leak would lose.  With both probs seen to the exhaust smells a whole lot better, compared to the choking smell before.  Dark smoke on hard accelaration has also gone presumably to do with the timing

To sum up, best improvement to the car so far.  As I said before, AT needs attention, rear suspension rubber replaced, ongoing work to the interior, and before to long a respray. (one day).
1973 350SE, my first & fave

oscar

  • W116 Addict
  • ****
  • Posts: 4,043
  • Location: Riverina, NSW, AUSTRALIA
Re: My 350se resto update
« Reply #1 on: 25 January 2006, 03:56 PM »
Hey Styria,

Good to hear from you again.  Your right about the cost, although I haven't received the bill yet, it'll be at least.....well I wont speculate, it'll be heaps of course.   

He has also replaced the leads on the right side and a suppressor on the left.  I'll have to get in contact with you soon re parts we've discussed previously.  I honestly don't know what I need or can afford yet.

Re the modulator valve, I swear the gear changes are smoother.  I still have a vaccuum leak, mainly passenger front lock.  Heater diaphragm changed last year with right rear lock.  That's all work in progress.

Re fuel economy.  I haven't bragged about figures in this thread because like you I can't believe the accuracy of my calculations.  The trip was from Wagga to Griffith.  Fuelled up before I left Wagga till I couldn't trickle any more fuel in, then did the same in Griffith.  It was a very hot day (approx 40oC) and assuming 90+ litres was cold in the tank, it would've warmed up considerably on the way and expanded.  Hows that for a possible explanation? I hope not.  Should've put this in the fuel consumption thread.  Anyways it's Australia Day and I have to work.  HURU.
1973 350SE, my first & fave

oscar

  • W116 Addict
  • ****
  • Posts: 4,043
  • Location: Riverina, NSW, AUSTRALIA
Re: My 350se resto update
« Reply #2 on: 26 January 2006, 07:30 AM »
Huru! Seemed appropriate for Aussie Day, the old Don Burke farewell, I must have hit CAPS LOCK.

I think before, the transmission would leap from 1st to 2nd when accelerating hard (not too hard).  On a slow take off it would knock or snap from 1st to 2nd.  My descriptions make the gear changes sound as though they were quite abrupt, but they really were tolerable.  The gear changes are that much better now though that I don't think I'll touch anything to do with the AT, just keep an eye on the ATF.  The car's at work at the moment whilst I'm on-call. 2 more days and I'll be gliding down the highway again for no reason in particular but for why not.

Still interested in parts though the list may have changed.  Will talk with you Styria on Friday (today) hopefully if work doesn't send me away.
1973 350SE, my first & fave

alabbasi

  • Vintage
  • ***
  • Posts: 587
  • Location: Dallas, TX
Re: My 350se resto update
« Reply #3 on: 09 March 2006, 07:44 PM »
Where are the pictures? You know we love pictures.. :)
With best regards

Al
Dallas, TX USA.

oscar

  • W116 Addict
  • ****
  • Posts: 4,043
  • Location: Riverina, NSW, AUSTRALIA
Re: My 350se resto update
« Reply #4 on: 10 March 2006, 04:32 AM »
Where are the pictures? You know we love pictures.. :)

I hear you.  For aesthetic appeal, there's no pics to drool over.  The fact is, nearly all the work on the car to date has been on maintenance or repair of mechanical aspects of the car, mostly engine, some suspension and a few hidden body work jobs.  I did have some pics in posts that were lost during the forum upgrade.  I'll make an effort after the weekend to dig thru my out of control digital cam library and find those lost pics and match them with jobs I've done.  Meantime, imagine a white 116 with colour coded 14" hubcaps and that's my car.  Still waiting for the bloody bill, so I can't move on with the next job.

BTW Alabbasi, if I haven't said it before, congrats on your impressive efforts on the 6.9.  Certainly gives inspiration to what can be achieved.
1973 350SE, my first & fave

michaeld

  • Classic
  • **
  • Posts: 433
Re: My 350se resto update
« Reply #5 on: 10 March 2006, 12:00 PM »
MB350,
Congratulations on money well-spent.  Imagine if you'd shelled out all those bucks and STILL had smoke and shifting issues!!!  Sounds like you fixed what ailed.
I am trying to read up on auto repair so that I can do more work on my own car and save money.  Auto electric makes for fascinating reading.

After I bought my 450 SEL, I put a stethoscope on my cylinder head w/ my heart pounding in fear - and was sooooooo happy when I heard only the soft, smooth whir of the motor.  But then, my girl's only got 125,000 miles.